Dateiberechtigungen und -größe als Fragezeichen (SSH)

  • Hallo zusammen,
    vielleicht kann mir jemand von Euch helfen, denn ich verzweifle langsam an folgendem Problem:

    Aufgefallen ist es mir, als es auf einmal total lang dauerte den Papierkorb zu leeren.
    Ich habe mich dann über ssh auf die NAS eingeloggt und nachgeforscht und gesehen, dass der rm-Prozess anscheinend nicht weiterkam.
    Dabei habe ich mit 'ls -l' ziemlich schnell herausgefunden, dass einige Dateien und Ordner im Papierkorb ein Fragezeichen in den Dateiberechtigungen hatten.
    Der Versuch die Dateien mit 'rm' zu löschen, oder mit 'chown' die Berechtigungen zu ändern ist mit der Meldung 'No such file or directory' gescheitert.
    Ich habe die Platte schon mit 'umount' aus dem System genommen und mit 'e2fsck' gecheckt. Ohne Ergebnis. Auch 'dmesg' zeigt mir, dass das Filesystem in Ordnung ist.
    Ich kann also die Dateien weder löschen, noch irgendwie bearbeiten.

    Hat jemand noch eine Idee?

    Danke

  • Hallo und willkommen im Forum.


    Sind das immer die gleichen Dateiendungen? Ein erkennbares Muster. Screenshots?

  • Hallo Rednag,


    nein. Mit Dateiendungen hat das eigentlich nichts zu tun. Ein bestimmtes Muster gibt es dabei auch nicht.
    Es kommt einmal auf einer Platte im Emby Server-Verzeichnis vor und auf einer anderen Platte im Papierkorb.
    Screenshot habe ich mal angehängt, damit Du siehst was ich meine.

    Ich durchforste gerade noch ein paar Linux Foren, da das kein spezielles QNAP-Problem sein sollte.
    Es kommt wohl auf allen Linux Varianten vor, aber bis jetzt lese ich immer nur von Lösungen die ich oben bereits beschrieben habe.

  • Es kommt einmal auf einer Platte im Emby Server-Verzeichnis vor und auf einer anderen Platte im Papierkorb.

    Betrifft dieses Phänomen also 2 verschiedene Ordner?

    Wie sind die Daten in den Papierkorb gewandert? Über QTS File Station, SMB/CIFS, AFP, NFS...?

  • Es betrifft sogar zwei verschieden Platten. Ich habe unter anderem noch einige Ordner im Emby Server unter .qpkg gefunden. Ist wirklich seltsam. Im Moment tippe ich eventuell auf die 16GB RAM, die anscheinend doch nicht kompatibel zur QNAP sind und mir irgendeinen Murks auf die Platte schreiben. Die Files werden von unterschiedlichen Stellen gelöscht. Filestation, SMB, Apple etc... kann ich leider beim Papierkorb nicht mehr nachvollziehen. Workaround für die Deinstallation des Emby-Servers war, dass ich mir die uninstall.sh angeschaut habe und die Sache händisch erledigt habe. Mit 'mv' konnte ich dann zumindest den Emby-Ordner umbenennen und neu installieren. Ist echt seltsam. Ich glaube ich hole mir mal den QNAP-Support ins Boot. Es sind zwar nur KB große Dateien und das macht bei 10 TB nix, aber wissen will ich es trotzdem.

  • Es wäre nett uns hier auf dem laufenden zu halten.

    Evtl. haben andere User auch solch Probleme.

  • Ohne Erfahrung mit dem Support zu haben, aber ich würde mal so etwa 1 Woche veranschlagen.

    Dann geht es vermutlich weiter mit Screenshots, Logfiles, Einstellungen....

  • Für das Problem gibt es eignetlich nicht so viele Ursachen.

    Die Fragezeichen signalisieren, dass hier ein inode gefunden wurde, dessen Handle ungültig ist.

    Es kann auftretern, wenn das Dateisystem kaputt ist, was Du ja mit dem Check schon geprüft hast.

    Gerne tritt es aber auch auf, wenn eine Datei verschoben oder gelöscht wird, während ein anderer Prozess da noch die Finger drin hatte. Die Rusachen können hier vielfältig sein, NFS Mountoptionen, ein Virenscanner von einem Client, etc.

    Allerdings sollte dieser ungültige Bezug verschwinden, wenn das NAS neugestartet wird- ich kann anhand dieses Themeas nicht erkennen, ob Du das schon getan hattest, auch wenn ich das vermute.

    Wenn diese ungültigen Dateibezüge nur im Netzwerkpapierkorb auftreten, wäre es interessant, ob sich nach Deaktiveren des Papierkorbs, Reboot der Qnap und reaktivieren des Papierkorbs etwas an der Situation verändert.

    Wenn das Problem bleibt, hast Du vieieicht einen Firmware-Bug entdeckt oder tatsächlich ein Hardwareproblem. Wäre wirklich interessant zu sehen, ob und was Qnap dazu sagen kann.

    Einmal editiert, zuletzt von sawachika ()

  • Im Moment tippe ich eventuell auf die 16GB RAM

    Hast du denn den originalen Speicher noch? Auf den wird der Support bestehen - zumal dein NAS (welches eigentlich?) vermutlich maximal 8GB unterstützen wird.

  • Habe das gleiche Problem.

    Das Modell TS-231P2 mit Aktueller Firmwareversion: 4.3.4.0644 kann den Backup nicht erstellen, weil auf die Daten welche früher mal gesichert wurden kein Zugriff besteht.


    Wenn ich mit dem Windows-Explorer im Sicherungs-Ziel-Ordner versuche eine Datei oder ein Ordner anzulegen kommt auch immer dei Meldung "Sie benötigen Berechtigung zur Durchführen des Vorganges"

    Wenn ich in den Eigenschaften die Atribute des Schreibschutzes für den Ordner und alles darunterliegende entfernen möchte kommt die Meldung "Das Handle ist ungültig"


    Mit dem langen Pfadnamen, sollte es eigentlich nicht zusammenhängen, da es früher ja mal funktioniert hat und das QNAP-Sicherungs-Tool dort ja die Daten früher selber hingeschrieben hat.