LOCALE - oder warum ist die Tastatur anders belegt ?

Keine passende Antwort gefunden? Dann frag uns doch direkt, kurz registrieren und los gehts!

  • LOCALE - oder warum ist die Tastatur anders belegt ?

    hallo,

    es gibt da ein Thema, das mich seit langer Zeit beschäftigt und regelmässig zur Verzweiflung bringt. Wenn ich eine virtuelle Maschine einrichte (meist eine ova von bitnami), habe ich nach der Installation das Problem, daß ich trotz Tastaturlayout = german immernoch eine englische Belegung in der VM habe (Zugriff per Browser Konsolenfenster). Jedesmal, wenn ich versuche, im Betriebssystem selber per locale-gen eine neue locale zu generieren, scheitert es daran, daß ich mit meiner Tastatur kein '=' schreiben kann. Es muss doch möglich sein, in der VM die locale zu setzen...

    Warum die Auswahl in den VM-Einstellungen selber keine Auswirkung hat, ist mir ein Rätsel.

    Mal von dem fehlenden Zwischenspeicher für die VM Konsole abgesehen, das ist ein anderes Thema...

    Hoffe, jemand hat da schon eine Lösung zu gefunden ?
  • Upps, da habe ich aber eben eine ganz andere Möglichkeit gefunden (und viel einfacher :) )

    Öffne einen Texteditor, schreibe das = hinein, kopiere das ins Clipborad, wechsle ins Putty Fenster und drücke die rechte Maustaste.
    Und schon ist das böse = im Terminal :D

    Gruss
  • jahaaa... auch das geht leider nicht, da diese eingeschränkte Konsole der Virtualization Station leider die Zwischenablage nicht nutzt... :(

    nächster Gedanke war, openssh-server zu installieren und per ssh drauf zuzugreifen. Was soll ich sagen ? Auch das hakt. Aber ich denke, daß das der einzige vernünftige Weg ist, die Konsole von QNAP nicht nutzen zu müssen.
  • Neu

    Moin,
    ja, den Gedanken habe ich auch gehabt und musste aber feststellen, daß Bitnami bei seinen Images erstmal ssh nicht freigibt. argh...
    Also, ssh aktivieren (hier speziell im Falle von Bitnami, Debian) :


    sudo rm -f /etc/ssh/sshd_not_to_be_run

    sudo systemctl enable ssh

    sudo systemctl start ssh

    Dann kommt man per ssh auf die Konsole.

    Nun installiert man das Paket console-data (wenn nicht schon vorhanden):

    sudo apt-get update

    sudo apt-get install console-data

    Mit einem

    sudo dpkg-reconfigure console-data

    kann man dann die entsprechende Keyboardbelegung und Sprache wählen. Im Fall von deutsch
    wäre das die Nummer 153.

    Schon viel besser jetzt... Noch nicht perfekt, da einige Zeichen immernoch nicht da sind, wo
    sie hingehören, aber immerhin. Damit kann man arbeiten