Selbsterstellter Ordner mit Inhalt verschwunden...

  • Hallo liebe Community,


    nachdem ich nun bereits mit Anfangsschwierigkeiten in Bezug auf den Zustand meiner Festplatten zu kämpfen hatte (Kein RAID1-Einrichtung möglich), ergibt sich nun ein neues Problem:


    Ich habe versucht, meine Daten per externer Festplatte mittels puresync-Synchronisation an einem Windows-PC auf die per Netzlaufwerk-eingebundenen Ordner auf dem NAS zu übertragen.
    Bei den Fotos, der Musik und Software gab es keine Probleme. Meine privaten Daten (u.a. Dokumente) habe ich in den erstellten Ordner "privat" kopiert.
    Hat alles soweit auch geklappt, allerdings war einen Tag nach der Übertragung der Ordner "privat" in der File Station verschwunden.
    Per SSH konnte ich Ihn unter /share/ finden und habe ihn gelöscht (rm -R).


    Allerdings wird der durch diese Daten belegte Speicherplatz offenbar nicht fregegeben und ich kann auch keinen neuen Ordner mit dem gleichen Namen erstellen, um die Daten erneut zu übertragen (das Feld Ordnername bleibt rot, als ob es den Ordner noch gäbe).


    Hat hier jemand eine Ahnung, woran dies liegen könnte?


    Danke & Gruß
    Martin

    Dateien

    • 1.jpg

      (202,07 kB, 15 Mal heruntergeladen, zuletzt: )
  • Der Ordner wird noch da sein. Wenn der ordner nicht mehr angezeigt wurde, dann war vermutlich der Symlink falsch. Das Löschen per SSH hat dann nur diesen entfernt - nicht jedoch das eigentliche Verzeichnis.

  • Danke zunächst einmal für die Info Michael.
    Der Ordner @privat wird im Verzeichnis /share auch immer wieder (nach jedem Neustart des NAS?) angelegt. Wenn ich allerdings diesen aufrufen will, heisst es "No such file or directory".


    Wo genau liegen dann meine Daten? Und wie stelle den Symlink wieder korrekt her?

  • Unter Systemsteuerung - Rechte - Freigabeordner kannst du die Einstellung korrigieren, indem du in der Freigabeeinstellung den Datenträger und Pfad korrekt auswählst.

  • Danke! Allerdings ist der Ordner versteckt und kann nicht bearbeitet werden. Und nun?

    Dateien

    • 2.jpg

      (275,43 kB, 20 Mal heruntergeladen, zuletzt: )
  • :D hab ich übersehen, sah für mich auf der ersten Blick alles gleich aus (und ich dachte es bezog sich lediglich darauf, dass alle diese Ordner verschlüsselt sein sollen)


    Klappt auf jeden Fall, vielen Dank! Warum auch immer ich es aktivieren musste...


    Was mich weiterhin wundert: Abgesehen vom Ordner photos sind die Größen falsch, da die Ordner bereits befüllt sind.

  • Das mit den Ordnergrößen ist mir auch schon aufgefallen, aber nach einiger Zeit stimmen die dann.
    Z.Zt. lasse ich auf meinen Testsystem ein paar Syncs durchführen, da zeigen die Ordner auch noch "0" an obwohl schon einige Dutzend GB drauf liegen...


    Gruss

  • Hallo,
    da bin ich mal wieder. Seltsamerweise ist der Ordner wieder versteckt/verschlüsselt nach einem Neustart des NAS.
    Zwar kann ich dies rückgängig machen, aber eine Dauerlösung ist das ja auch nicht.
    Die Ordneroptionen von "privat" sind identisch mit meinen anderen verschlüsselten Ordnern, die offenbar automatisch beim NAS-Start entschlüsselt werden bzw. zumindest nicht versteckt werden.

  • Hallo, habe ein ähnliches Problem.

    Es fing alles damit an, daß ich mal mit Owncloud X. Da gibt es immer nach der Installation am Anfang eine Fehlermeldung,

    dass das Internationalisation Modul fehlt. Nun gut Modul besorgt und unter mnt/ext/opt/apache/modules reinkopiert.

    In die PHP.ini noch den Eintrag extension=intl.so eingebaut und fertig. Installation gecheckt, Fehler immer noch da.

    Webservre rebootet- Fehler noch da. QNAP gebootet -Fehler noch da. Ins Verzeichnis geschaut, nach dem Reboot fehlt die Datei intl.so. Schritte oben wiederholt und nach jeden Schritt PHPINFO anzeigen lassen. intl.so wird niemals angezeigt.

    Die Datei verschwindet aber definitiv aus dem Verzeichnis nach einem Neustart des QNAP.


    Heute habe ich dann Nextcloud installiert. Da ich, wie in der Anleitung beschrieben aus Sicherheitsgründen die Daten in ein

    anderes Verzeichnis auslagern möchte, habe ich zusätzlich Verzeichnisse angelegt z.B. Unterhalb von var oder auch etc.


    var/www/nextcloud/data/

    oder

    etc/www/nextcloud/data/


    Tja, was soll ich sagen, nach einem Reboot des QNAP sind die Verzeichnisse weg.

  • var/www/nextcloud/data/

    oder

    etc/www/nextcloud/data/


    Tja, was soll ich sagen, nach einem Reboot des QNAP sind die Verzeichnisse weg.

    Logisch bei Verzeichnissen in der RAM-Disk.