autorun feature

  • Hi,


    im Changelog steht Added the option to execute an autorun script upon NAS startup.
    Weiß jemand wie das funktioniert? In den Einstellungen kann ich mir die nur anzeigen lassen aber nicht bearbeiten.

  • Hallo,


    ich suche das Feature auch. Wobei ich bisher nichtmal die Anzeigemöglichkeit gefunden habe.
    Gibt es hierzu schon etwas neues?

  • Also die Einstellung dazu ist zu finden unter Systemsteuerung -> Hardware. Aber mehr kann man da dann auch nicht machen.

  • Ah sehr gut vielen Dank.
    Denn nach meinem Update haben meine in der Autorun getätigten Änderungen nicht mehr funktioniert. Durch dich weiß ich jetzt dass man den Hacken seit dem Update setzen muss und siehe da sie gehen wieder.
    Ich dachte schon sie hätten eine praktische Funktion hinzugefügt womit man auch gleich editieren kann.


    Wie man das autorun.sh editiert steht in diesem Wiki Artikel.
    https://wiki.qnap.com/wiki/Run…wn_Application_at_Startup

  • Meine Autostart.sh kann ich jetzt zwar in den Einstellungen angucken aber funktionieren tut sie trotzdem noch nicht :-(
    Manuel funktioniert es, nur beim autostart nicht...

  • Nicht viel, nur ein Programm starten. So sieht sie aus:

    Shell-Script
    1. #!/bin/sh
    2. /share/CACHEDEV1_DATA/.qpkg/Entware-ng/bin/python /share/CACHEDEV1_DATA/.qpkg/Radicale/radicale.py -C /share/CACHEDEV1_DATA/.qpkg/Radicale/config

    Hatte vorher ne autostart.qpkg installiert, dass hat immer funktioniert. Nach dem Update letzten Update wurde diese aber leider funktionsunfähig gemacht.


    Wie sieht denn deine autostart aus?

    Einmal editiert, zuletzt von bmn ()

  • Hallo,


    Qnap hat Alles was mit mit "autorun" zu tun hat in der neuen Firmware nur "verschlimmbessert"!


    Beide Möglichkeiten zur Ausführung einer "Autorun" gehen nicht mehr, weder die MTD Variante ( https://wiki.qnap.com/wiki/Run…wn_Application_at_Startup ) noch die Variante über die "qpkg.conf" !
    In der "qpkg.conf" wird bei jedem Start für den Eintrag "Autorun" der Wert Enable = TRUE auf Enable = False gesetzt.


    Für die MTD Variante:
    In der /etc/init.d/init_nas.sh wurde die Prüfung eingebaut ob der Haken für die Ausführung "Benutzerdefinierte Prozesse" gesetzt ist.
    Zu finden unter Systemsteuerung -> Hardware. Egal ob Haken gesetzt wir - die Änderung wird nicht in der /mnt/HDA_ROOT/.config/uLinux.conf gespeichert. Unter dem Block [Misc] erscheint der Parameter Autorun = TRUE nicht! Diesen Wert manuell in die /mnt/HDA_ROOT/.config/uLinux.conf einfügen und dann läuft zu mindest die MTD Variante wieder.
    Der 2. Fehler tritt bei Geräten mit ARM Prozessor auf!



    mfg kasimodo

    Einmal editiert, zuletzt von kasimodo ()

  • In der uLinux.conf ist bei mir ein Autorun=True aber gesetzt. Aber das Programm starten tut er trotzdem nicht.


    -edit-
    Ok, einen ARM Prozessor habe ich nicht. Ich habe mal einen cp Befehl eingefügt und der geht. Grundsätzlich scheint der autostart dann wohl zu funktionieren nur mein Programm startet er nicht, warum auch immer...

    Einmal editiert, zuletzt von bmn ()

  • Hi,


    Da ich keine Glaskugel habe bitte ich darum euer Profil mal auszufüllen! NAS Typ eintragen und dazu die QTS Version!


    Autorun=True ist NUR für die MTD Variante der Autostart zuständig! Läuft unter meinem TestNAS mit Intel und mit dem beschriebenen manuellen Eintrag in der /mnt/HDA_ROOT/.config/uLinux.conf auch unter ARM Nas.


    Das Eintragen einer eigenen Anwendung in die "qpkg.conf" (Autorun) wir in der aktuellen Firmwareversion von QNAP bewusst und aktiv geblockt!

    Vielen Dank an QNAP für die Bevormundung :evil: !!!!!!! :o(

    Qnap hat in die /etc/init.d/init_qpkg.sh eine Funktion check_qpkg_official() eingebaut!

    Diese Funktion setzt eure Anwendung Autorun auf Enable = False


    Hier der Code aus der init_qpkg.sh (Ausschnitt):

    Shell-Script: init_qpkg.sh
    1. ....
    2. check_qpkg_official()
    3. {
    4. /sbin/qpkg_cli --check_official 0 2>/dev/null 1>/dev/null
    5. }
    6. ....

    Hier die Hilfe zur Bin: /sbin/qpkg_cli --check_official

    3 Mal editiert, zuletzt von kasimodo ()

  • Grundsätzlich finde ich das als NORMALUSER, der das NAs "nur" benutzt, ganz gut, wenn dadurch Malware effektiv geblockt wird.


    ABER: Es muss eine Option geben, dass POWER-USER das natürlich anders einstellen können.


    QNAP scheint das Update auf die 4.3.3 final (bei mir 4.3.3.0262) ganz schön verbockt zu haben.


    In der Update-Info von QNAP waren die ganzen Einschränkungen (64bit-Änderungen bei etlichen Apps, Samba-Update, vieles andere mehr) NICHT klar zu erkennen. So macht das keinen Spaß...


    Vielleicht solte QNAP sich mal überlegen,

    • besser zu kommunizieren, und
    • VOR dem Update des QTS ERST die Apps (!) zu aktualisieren, DAS könnte viel Ärger sparen!!!
  • So, ich habe die eine Scriptzeile jetzt einfach mit in das Entware-ng.sh script gebaut. Das funktioniert. Ein eigenes autorun.sh hätte mir zwar besser gefallen aber das ist wohl leider nicht möglich. Trotzdem Danke für die Tipps ;-)

  • Ich hab mir folgende Lösung gebastelt um das Deaktivieren von eigenen bzw. von Qnap nicht erwünschten APPs zu umgehen.
    Also nicht nur für die "AutoRun" geeignet.


    Folgend Schritte:


    1. Eine "autorun.sh" wie hier beschrieben wiki.qnap.com/wiki/Running_Your_Own_Application_at_Startup mit folgenden Inhalt anlegen!


    Shell-Script: autorun.sh
    1. #!/bin/sh# AUTORUN.SH - "Boot strap"echo `date` Start autorun MTD > /var/log/autorun.log/etc/config/autorun.sh


    Achtung! darauf achten, dass in der /mnt/HDA_ROOT/.config/uLinux.conf unter dem Block [Misc] der Parameter Autorun = TRUE vorhanden ist.


    2. Eine "autorun.sh" unter /etc/config mit folgenden Inhalt anlegen!



    Datei muss ausführbar sein - Rechte setzen!

  • nach 5 tagen die erste antwort

  • Bei mir funktionieren die selbstgebastelten autorun geschichten immer noch wunderbar. Habe auch die qpkg Lösung. Hier der Eintrag meiner qpkg.conf:



    Code: qpkg.conf
    1. [autorun]
    2. Name = autorun
    3. Version = 0.64
    4. Author = XY
    5. Date = 2017-03-20
    6. Shell = /share/CACHEDEV1_DATA/.qpkg/autorun/autorun.sh
    7. Install_Path = /share/CACHEDEV1_DATA/.qpkg/autorun
    8. QPKG_File = autorun.qpkg
    9. Enable = TRUE

    Habe noch einige weitere einträge mit anderen Namen. so habe ich die Möglichkeit verschiedene Scripte die ich betreibe via GUI ein und auszuschalten.


    Offtopic: Ich bin noch auf der Suche nach einem guten und einfachen Tutorial um eine GUI für eine APP in QTS zu bauen. Hat da jmd. infos?

  • @kugelkopf


    es ist zum verrückt werden - du hast recht!!
    Die "qpkg" Methode der autorun funzt wieder. Das Symbol ist im AppCenter auch nicht mehr ausgegraut.
    Wenn ich es vorher nicht selbst so intensiv getestet hätte, ich würde zweifeln!


    Mein Eintrag in der qpkg.conf sah bis auf zwei Kleinigkeiten genau so aus wie du oben geschrieben hast. Nur Version war die 0.1 und bei Author stand etwas anderes.
    Einzig den Eintrag Autorun = TRUE habe ich manuell nun in die /mnt/HDA_ROOT/.config/uLinux.conf eingetragen. Aber dies sollte ja nur für die MTD Methode relevant sein.

  • hurra
    mit dem update auf die 0299 hat sich das problem erledigt
    die autorun bleibt auch nach dem neustart eingeschaltet
    (benutzerdefinierte prozesse beim start ausführen)


    mfg albert