[Howto] Eigenes Zertifikat mit "qnap-letsencrypt"

  • Da ich für die Bedienung des NAS von außen andere als die Standard-Ports (443) benutzen möchte, klappt das leider nicht so einfach.

    Ich hatte auch probiert sowohl den Port 443 als auch 80 auf das NAS per Portweiterleitung zu nutzen, es funktionierte aber nicht, warum auch immer.


    Mit der neuen Fritz!Box Firmware hat sich das Problem aber wahrscheinlich sowieso erledigt, da die auch direkt Let's Encrypt unterstützen soll. Dann kann ich das Zertifikat dort exportieren und in das QNAP importieren und fertig.

  • Dann kann ich das Zertifikat dort exportieren und in das QNAP importieren und fertig.


    Toll wäre es wenn man dies dann auch noch mit einem Script machen könnte. (vom NAS aus)


    Grüße

    Kasimodo


    ps: bei meiner alten Fritte kann ich über ein Script vom NAS aus Ports öffnen und schließen. Leider habe ich dies für die neuere Firmware nicht hin bekommen.

  • Hallo,


    Bei mir hat das Script super funktioniert. Vielen Dank für die Hilfe.


    Weiß einer wie ich die Dateien exportieren kann, bzw. wo sie genau liegen?

    Oder vielleicht wie ich daraus eine pfx-Datei mache?



    Ich konnte mir selbst helfen ;-)


    vielleicht für den ein oder anderen auch Interessant:


    # Eingabe via SSH


    cd /opt/qnap-letsencrypt/letsencrypt

    openssl pkcs12 -export -in chained.pem -inkey account.key -out output.pfx


    # beliebiges Passwort eingeben

    # output.pfx wird unter "/opt/qnap-letsencrypt/letsencrypt" erzeugt

    Einmal editiert, zuletzt von asp27 ()

  • Nun ist es wieder an der Zeit und es klappt wieder nicht, liegt es an der neuen Firmware?

    Port 80 ist offen, in meinem Fall unter Service Binding ist Web Server auch aktiviert, Web Server an sich ist auch aktiviert, ich komme über die DynDNS Adresse auch auf die Webseite per http, also Port 80, und dennoch will es nicht klappen.


    Edit: Verrückt, einfach eine Stunde gewartet, nochmal probiert, und es funktioniert. Unerklärlich.

    Einmal editiert, zuletzt von UpSpin ()

  • Servus,


    hat jemand eine Idee, warum das aktuelle Zertifikat erst nach einem Neustart der NAS genutzt wird? Obwohl das neue Zertifikat erfolgreich erstellt wurde.

    Danke.


    Viele Grüße,


    Fbn

  • Mit der neuen Fritz!Box Firmware hat sich das Problem aber wahrscheinlich sowieso erledigt, da die auch direkt Let's Encrypt unterstützen soll. Dann kann ich das Zertifikat dort exportieren und in das QNAP importieren und fertig.


    Tja, zumindest für mich funktioniert das leider nicht. Die Funktion wird von der Fritz!Box leider nur für den MyFritz Zugang angeboten. Dort wird ja mit <krytischerName>@myfritz.net gearbeitet. Ich benutze das aber über einen anderen dyndns Provider, der auch vernünftige Namen anbietet, die man sich merken kann.

  • Nachdem ich jetzt auch mit der Zertifikatserneuerung (über die Systemsteuerung) langsam am verzweifeln war, weil sich das Zertifikat einfach nicht erneuern lassen wollte,

    , bin ich jetzt auch mal der Anleitung hier gefolgt und hatte innerhalb weniger Minuten ein funktionierendes SSL Zertifikat - danke!

    Bin schon gespannt wie die automatische Erneuerung läuft - ich hoff ich kann mir in Zukunft die ganze Probiererei über die Systemsteuerung damit ersparen!

  • und wenn du nun einmal ein funktionierendes Zertifikat hast, dann versuche jetzt mal über die Systemsteuerung ein neues Zertifikat anzufordern ;-) (das jetzt schon vorhandene nicht vorher deaktivieren!)


    mal sehen, wie da denn deine Erfahrungen sind! :-)

  • Hallo,


    Ich habe auch das Skript benutzt um ein Zertifikat benutzen würde es gerne für das Plugin WebTools von Plex benutzen.

    Leider finde ich die .crt und .key datei nicht welche ich in WebTools einbinden kann.