SMB version and SMB update

  • I would have to know how to set up the Samba version used in my NAS. I am using a TS-219P+ and QTS 4.2.0 (yesterday updated). In https://www.qnap.com/i/en/tuto…ow.php?op=showone&cid=184 it is shown how to 'set the “Highest SMB version” to “SMB 3.0” .' in 'advanced options'. But when clicking 'advanced options' this option to set the highest SMB version is not shown. Furthermore I would have to know which SMB version is ued in QTS 4.2.0. Where can I get this information?

  • Hi,


    please post your request next time in german ;) ... if the option is not shown, it might be not supported by your model!


    regards
    Christian

  • Schade, dass dies nicht in dem erwähnten Web-Link so kommuniziert wird.
    Es scheint aber ein Problem mit SMB zu geben, denn seit dem letzten Firmware-Update funktionieren die Windows-Workgroups plötzlich wieder.

  • Bei QTS 4.1 gab es noch diese Option auf meinem TS119 und jetzt ist sie weg, vieleicht habe ich deshalb probleme mit der Transferrate bei den TS119 mit Jumbo Frames :(

  • Habt ihr mal den Browser-Cache geleert?


    Also bei mir gibt es die Option zum Setzen der SMB-Version noch, allerdings hat mein 253pro eine SMB-Firmware.
    Ihr könnt über Putty prüfen, welche SMB-Version aktiv ist bzw., so denn vorhanden, auf SMB 3.0 wechseln. SMB 3.0 wird meines Wissens erst ab Samba 4 unterstützt.


    Aktive SMB-Version anzeigen:

    Code
    1. smb2status


    Ergibt bei mir:

    Code
    1. smbd (samba daemon) Version 4.0.25smbd (samba daemon) is running.max protocol SMB 2.1 enabled.


    Wechseln auf SMB 3.0:

    Code
    1. smb3enable

    (vermutlich ist ein Neustart des Samba-Servers danach notwendig)


    Wieder auf 2.1 wechseln:

    Code
    1. smb21enable


    Ich habe im Zusammenhang mit dem Upgrade auf Windows 10 mit SMB 3.0 experimentiert und festgestellt, dass zumindest bei mir die Datenrate leicht schlechter ist (ohne Jumbo Frames) als mit SMB 2.1. Da ich keine Verschlüsselung benötige, bleibe ich bei SMB 2.1.

    2 Mal editiert, zuletzt von dr_mike () aus folgendem Grund: smb2enable --> smb3enable, weteren Typo korrigiert sbm21enable --> smb21enable

  • warpcam:handbuch:


    Du bist genial, endlich wieder auf meinen Ts119 Samba performance von >80 MB/sec.
    Auf meinen TS119 war unter 4.2 Samba 1.0 aktiv, bei mir war der Unterschied 74MB/sec

  • Hey, das kam mir doch gerade recht :D


    Hatte hier schonmal ein kleines SAMBA-Tänzchen mit dem Intel-NAS:
    http://forum.qnapclub.de/viewt…it=samba&start=10#p206799


    Mein ARM NAS ist seit einiger Zeit auch ultra langsam und da ich dort keine SMB-Auswahl (mehr) habe, habe ich kurzerhand mal abgetippt :thumb:


    Was soll ich sagen? Irgendwie fand wohl beim Update auf 4.2.0 ein SMB-Downgrade auf 1.0(!) statt :shock:


    ^^ schnell mal auf 2.1 angehoben; 3.0 wird wohl generell nicht mehr nachgereicht (s. oben verlinkter Thread).


    Edit:
    Gibt's auch nen Befehl, asynchronen E/A unter SMB2.1 zu aktivieren? Für's Datengrab ist das nicht systemkritisch...


    Nachtrag:
    Das TS-212 ist einfach eine Krücke (256 MB RAM und viel zu langsame CPU), aber seine 34-53 MB/s macht's jetzt wieder :thumb:
    (Für's Medienstreaming absolut ausreichend)

  • Tja, bei mir war auch die 1.0 aktiviert. Werde mal heute Nachmittag nach der Schicht testen.
    Schöne Osterfeiertage wünsche ich allen. :qnap:

    Dateien

    • putty.png

      (30,45 kB, 425 Mal heruntergeladen, zuletzt: )
  • Zitat von "YellowFellow"

    Edit:
    Gibt's auch nen Befehl, asynchronen E/A unter SMB2.1 zu aktivieren? Für's Datengrab ist das nicht systemkritisch...


    habe auch bei meinem HS-251 asynchronen E/A aktiv und noch nie probleme gehabt :D

  • Hi,
    nutze noch eine Firmware vor 4.x
    dort gibt es den Befehl smb2status gar nicht.
    Kann wer helfen?

  • Kenne die Firmware erst ab 4.2 könnte sein das deine Firmware dieses gar nicht anbietet bzw. das die Samba Version es noch nicht unterstützt...


    SAMBA 3.5.2 = SMB1.x
    SAMBA 3.6.0+ SMB2.0
    SAMBA 4.0.25 SMB2.1 und 3.0 (zumindest bei der Firmware 4.2)


    Kannst eh leicht herausfinden, SSH auf das NAS, und dann:
    /mnt/ext/opt/samba/sbin/smbd -V
    ausführen und es wird dir die Version angezeigt.....

  • Zitat von "Unrealswebmaster"

    habe auch bei meinem HS-251 asynchronen E/A aktiv und noch nie probleme gehabt :D


    Das war aber nicht meine Frage ;)


    SMB-Versionen & Async E/A lassen sich bei den Business QTS-Versionen über die Einstellungen konfigurieren (Klicken/Häckchen setzen), bei den abgespeckten QTS-Versionen (wie der des TS-212) nicht.


    Daher muss man hier über's Terminal gehen und Linux-Befehle eingeben.
    So geschehen für's Update von SMB1.0 auf SMB2.1 (s. vorher im Thread).
    Meine Frage war nun ob es auch einen entsprechenden LINUX-BEFEHL für async E/A gibt und wenn ja, wie lautet dieser?


    Minutourus: Beim TS-670 bleibt er aus, bis ne USV verbaut ist und das TS-212 ist nur ein kleiner lahmer Medienserver, von dem meist nur gelesen wird und das auch nicht allzu oft. Damit ist ein Risiko relativ gering und RAID1 gäb's dann ja auch noch für den Fall der Fälle...

  • Habe gerade meine TS221 lt Vorschlag und Anleitung von WarpCam per Terminal auf SMB21ENABLE hochgeschaltet, jetzt erkennt mein Apple Finder das NAS nicht mehr, nur noch AFP funktioniert.


    Wie kann ich auf SMB 1.0 zurückschalten? Oder kennt jemand den Grund, warum die höhere Version von MacOS nicht gefunden wird?


    Lg Karl

  • Hi,


    ich habe ein ähnliches Problem. - TS231P - Aufnahme von Digisat hd2 problemlos, ohne ruckeln, einwandfrei. Jedoch eine Datei unter Win7 öffnen,kopieren, speichern, (nextcloud/remote.php/webdav) dauert eine halbe Ewigkeit. Ein ändern von SMB brachte keine Besserung.


    Switches Gbit Standard, ebenfalls der Netzwerkanschluss am Laptop


    Im übrigen lässt die Geschwindigkeit ebensfalls via MacBook und WinXP rechner zu wünschen übrig... :-(