Qsync Gerätedatenbank abgestürzt

  • Hallo,
    nachdem ich bisher nur mitgelesen habe, muß ich jetzt meine erste Hilfe-Anfrage stellen.
    Ich habe eine QNAP TS-110 mit der aktuellsten Firmware 4.2.0 vom 30.1.2016. Darauf läuft Q Sync Central Station 2.0.
    Auf mehreren Windows-Clients ist Qsync 2.2.0.2016.
    Derzeit kommt auf mehreren PC/Notebooks nach dem Windowsstart von Qsync die Fehlermeldung
    "Die Gerätedatenbank ist abgestürzt. Starten Sie das NAS bitte neu, um sie neu zu erstellen."


    Doch auch das hilft nicht weiter. Auch ein erneuter Start der PC/Notebooks bringt keine Änderung.


    Was mir aber in Qsync Central Station über die Weboberfläche auf dem NAS aufgefallen ist und wo der Fehler liegen könnte:
    Dort ist mein PC unter den 7 Geräten (von mir als Benutzer) 2x als erfasst und angemeldet, jeweils mit der gleichen IP und der Möglichkeit, die Verbindung zu trennen.
    Bei der 2. vorhandenen Anmeldung, die 13 Tage zurückliegt, taucht auch keine Versions-Nr für den Qsync-Client auf.
    In den letzten Tagen synchronisierte Qsync auf diesem PC an manchen Tagen einwandfrei.


    Was kann ich tun, um das Problem zu lösen?
    In der Geräteverwaltung von Qsync Central Station tauchen 2 Aktions-Schalter auf, die für mich in Frage kommen:
    a) "Dieses Gerät entfernen"
    b) "Gerät extern löschen"


    Was passiert dabei und welche muss ich anwenden, um meinen Synchronisations-ordner auf dem PC nicht zu verlieren?


    Wer kann bitte weiterhelfen?


    Mit freundl. Gruß
    Bernd

  • Hallo Bernd,


    helfen sollen diese Befehle (evtl. den Pfad für den ersten Code Schnipsel anpassen)

    Code
    1. cd /share/CACHEDEV1_DATA/.system/data/mysql


    Code
    1. myisamchk - V -fr proc


    Grüße
    Christian

  • Zunächst danke für Deine Antwort, Christian.


    Ich kenne mich auch aus in der Eingabeaufforderung von Windows.


    Aber ich vermute, dass ich die Befehle als Admin auf der QNAP eingeben muss.


    Wie mache ich das am einfachsten und besten?


    Gruß
    Bernd

  • Hallo,


    du musst dich mit dem SSH Programm "Putty" verbinden...


    Dann hast du eine Eingabeaufforderung für dein QNAP.

  • Hallo Christian und Stefan,
    Putty hab ich installiert und auch Zugang auf meiner TS-110.
    Jetzt geht es -wie ich es verstehe- darum, den Speicherplatz der MySQL-Datenbank zu finden.
    Wie finde ich den?


    Im Ordner "share" hab ich die Ordnerstruktur, die ich als Dateianhang beigefügt habe. Darin ist auch die Root-Ordnerstruktur ersichtlich.


    Wie muß ich auf der Konsole weitermachen?


    Gruß
    Bernd

  • Code
    1. cd /share/CACHEDEV1_DATA/.system/data/mysql


    Gib das in die Konsole ein

  • Hallo, Stefan


    das hab ich schon eingegeben, aber dann kommt die Meldung:
    no such file or directory


    Gruss
    Bernd





    --- ModEdit ---


    Ich hab jetzt noch mal in ähnlichen Forum-Threats nachgesehen.
    Dabei bin ich wenigstens einen Schritt weitergekommen.


    Der ursprüngliche Pfad muß heissen:

    Code
    1. cd /share/HDA_DATA/.system/data/mysql


    Dann bin ich in einem Verzeichnis, wo u.a. auch eine user.MYD und eine user.MYI sind.


    Wenn ich dann aber den von Christian empfohlenen 2 Befehl eingebe, kommt die Meldung:

    Code
    1. [/share/HDA_DATA/.system/data/mysql] # Myisamchk -V -fr proc
    2. -sh: Myisamchk: command not found


    Vielleicht hilft das Euch ja bei der Fehlersuche weiter.


    Gruss
    Bernd

  • Hallo,


    der letzte Tip von dr_mike hat zwar das gleiche Ergebnis gebracht (no such file or directory).


    Aber der erste von mir später angepasste Code-Schnipsel hat offensichtlich weitergeholfen.
    Nach einem Neustart der QNAP ist die Fehlermeldung "Datenbank abgestürzt" jetzt verschwunden und das Syncen funktioniert wieder.


    Vielen Dank an alle Helfer!


    Gruß
    Bernd

  • Zitat von "bernd4"

    Aber der erste von mir später angepasste Code-Schnipsel hat offensichtlich weitergeholfen.

    Nein, mit dem wechselst du nur ins Verzeichnis. Da hat dann eher der erneute NAS-Neustart geholfen.

  • Habe mit neuer Firm- und Software ein ähnliches Problem bei einem TS-212:
    Firmware: 4.2.0 / 4.2.1 (beide probiert)
    Qsync-Clients: 3.0.0.0413


    Bin nicht unbedingt qualifiziert, um per SSH dem Ding auf den Leib zu rücken. Aber Neustarts reichen leider nicht aus, um die Gerätedatenbank nicht abstürzen zu lassen. Ich habe außerdem versucht, die Clientsoftware neu zu installieren, die Userdaten neu einzugeben und mich für mein Unvermögen zu schämen. Hat bisher alles nicht geholfen.

  • Hi,


    was steht im Protokoll vom NAS und was wurde evtl. kürzlich am PC/Client oder am NAS geändert? Du kannst auch in den Einstellungen von Qsync auf den Debug Modus aktivieren siehe Screenshot:




    Wenn du den Fehler identifiziert hast, kannst ihn gerne hier einstellen und frage beim Support in Taiwan für dich nach oder aber du erstellst ein Ticket bei QNAP selbst und wartest auf eine Antwort.


    Grüße
    Christian

  • Vielen Dank für die Antwort. Da es an mehreren Clientrechnern, an denen natürlich in letzter Zeit nicht an allen das gleiche geändert worden ist, hatte ich die Clientseite als Fehlerquelle eigentlich erst einmal ausgeschlossen. Am NAS habe ich zuletzt die LimeSurvey-App installiert, aber noch nicht viel mit gespielt. Und dann waren da die Updates der Photo Station, die aber kaum genutzt wird.


    Im Protokoll vom NAS steht das hier:



    Edit: Sorry, das nennt man - glaube ich - Spam. Wollte aber nichts auslassen, weil ich nicht wusste, was wichtig sein könnte...


    2. Edit: Habe LimeSurvey wieder deinstalliert und daran hat's dann wohl gelegen, denn jetzt geht es wieder!

    Einmal editiert, zuletzt von dr_mike () aus folgendem Grund: Quote durch Codeblock ersetzt.

  • Hallo habe genau dasselbe Problem nach einem Firmwareupdate.
    Soweit bin ich schonmal mit putty gekommen:
    Nach:
    cd /share/HDA_DATA/.system/data/mysql
    bin ich im Verzeichnis und sehe 3 Dateien:
    user.MYD
    user.MYI
    user.frm
    Nachdem Befehl:
    /usr/local/mysql/bin/myisamchk - V -fr proc


    Kommt folgende Fehlermeldung:

    Code
    1. error: Found option without preceding group in config file: /etc/my.cnf at line: 2
    2. Fatal error in defaults handling. Program aborted



    Wie gehe ich weiter vor???
    DANKE
    Michael

  • Hallo zusammen,


    hab das gleiche Problem mit meiner 239. Hab mich hier schon durch's Forum gewühlt und auch auch den MySQL Pfad gefunden. Ist merkwürdigerweiser noch einmal ein anderer (MDO_Data, unter HDA_Data findet man gar nichts).


    Aber wenn ich myisamchk ausführen will, bekomme ich Fehler, dass dieses Kommando nicht gefunden werden kann. Bin ich vielleicht doch im falschen Pfad?


    Das Problem scheint auch bei mir mit dem Frmeware-Update zusammen zu hängen. War im Urlaub und nach dem Urlaub klappt der Sync nicht mehr. Firmeware ist die 4.2.2 vom 1.9.16


    Hat jemand eine Idee?


    Besten Dank vorab.


    Sonnige Grüße
    André

    Einmal editiert, zuletzt von Andre77 ()

  • Habe auch das gleiche Problem. Erst verbindet er sich mit grünen Haken
    dann fängt er wieder an zu suchen dann kommt die Fehlermeldung
    (Ungewöhnlicher Status) ..die Gerätedatenbank ist abgestürzt.



    Bin heute auf eine alte Firmware zurückgegangen (20160311-4.2.0) jetzt läuft QSYNC wieder einwandfrei.


    Es liegt also an der Firmware.

  • Das mit der Firmware kann ich so nicht bestätigen. Bei mir hat es das Problem nicht gelöst. Ich habe festgestellt, dass der Fehler beim Qsync nur beim Zugriff über LAN auftritt, nicht aber über WLAN. Firewall und AV kann ich ausschließen.


    Den Support hat ich bereits vor über 3 Wochen angeschrieben. Da kam nur eine Mail, wo auf die Überlastung des Supports hingewiesen wurde und ein Verweis auf die FAQs gegeben. Leider wenig hilfreich.


    Pfade habe ich auch schon auf der NAS- und auf der Client-Seite geändert, leider aber auch ohne Erfolg.


    Für jeden weiteren guten Tipp bin ich sehr dankbar.

  • Ich hatte ein ähnliches Problem. Der myisamchk lief nur mit einer Fehlermeldung der MySQL config Datei. Daraufhin habe ich mir die Datei (/etc/config/my.cnf) angesehen und vergestellt das sie beschädigt war. Nachdem ich sie wieder hergestellt hatte, könnte ich mich unter Windows wieder mit QSync anmelden.

  • TS-212P gekauft, neben anderen Problemen kommt bei Qsync ständig die Fehlermeldung "Gerätedatenbank abgestürzt, NAS neu starten". Was für ein Sch... wenn man bedenkt, dass das Gerät als All-in-one NAS für Homeuser und alles als "sehr einfach" verkauft wurde! Mittlerweile echt nervig!


    Firmware 4.2.2
    Qsync 3.1.0.0817
    Zugriff per LAN.


    Mit commandobefehle etc. kenne ich mich nicht aus.


    Von daher würde ich gerne wissen ob es eine einfache Fehlerbehebung gibt?

  • Hallo zusammen,


    zwischenzeitlich habe ich eine Antwort vom QNAP-Support mit einem Verweis auf eine neue QSync-Version erhalten. Ich habe die alte deinstalliert, die Registry bereinigt und die neue installiert, leider jedoch auch hier ohne Erfolg.


    Möglicherweise gibt es aber vielleicht mehrere Ursachen und die Lösung hilft anderen, daher die Antwort des Supports mit dem Link:




    ---