[Howto] JDownloader2 auf QNAP-NAS (x86 und ARM)

  • Solange noch die Möglichkeit besteht, nur durch eine kleine Script-Änderung den JD2 zum Laufen zu kriegen, ist eine neue Investition keine Option. Sorry, Geld wächst nicht auf Bäumen.

    Die TS-412 tut Ihren Dienst und solange sie dies tut, bleibt sie auch.

  • Die Installation sollte weiterhin funktionieren, allerdings wurde das entware-ng & entware-3x Projekt zusammengeführt und wird als neues Projekt entware fortgeführt. Den Installer gibt es hier -> http://bin.entware.net/other/Entware_1.00std.qpkg


    Es muss dann noch Java installiert werden, danach kann man den jdownloader2 mit dem folgenden an das neue entware Projekt angepassten Script installieren


    JD2_Qnap_installer.zip


    Nach der Installation muss das Start Script JDownloader2.sh unter /share/CE_CACHEDEV1_DATA/.qpkg/JDownloader2 gegen die folgende an das entware Projekt angepasste Version ausgetauscht werden.


    JDownloader2.zip

    2 Mal editiert, zuletzt von libertyx82 ()

  • Hi,

    vielleicht bin ich zu dämlich. Aber ich habe die Installation "streng nach Vorschrift" durchgeführt. Nachdem das Script (JD2_Qnap_installer.sh) durchgelaufen ist, hatte ich dann auch die entsprechenden Verzeichnisse

    (/share/MD0_DATA/.qpkg/JDownloader2). Fix die JDownloader2.sh getauscht. Fertig. Dachte ich. Nix da. Ein Start per AppCenter oder "java -jar JDownloader.jar &". Am Ende sagt my.jdownloader.org nur

    Code
    1. "No connected JDownloader found."

    Gibt es keine andere Möglichkeit den JD drauf zu kloppen? Ich hab im übrigen ein altes TS-419PII. Aber irgendwie häng ich dran.

  • Welches Script hast du denn benutzt, das originale oder das von mir abgeänderte?


    Es muss inzwischen auch Entware genutzt werden, da Optware nicht mehr supported / weiterentwickelt wird.

  • Hi,

    als erstes... ich habe Entware-std 1.00 und Entware-ng 0.97 installiert. Anschließend bin ich strikt nach deiner Anleitung vorgegangen und habe auch deine JDownloader2.sh drauf kopiert.

    Was mich aber bereits beim studieren deiner Anleitung verwirrte... das angegebene Verzeichnis

    "/share/CE_CACHEDEV1_DATA/.qpkg/JDownloader2" existiert nicht. Statt dem CE_CACHEDEV1_DATA habe ich MD0_DATA. Aber ich behaupte mal, das ist dem NAS geschuldet und spielt keine größere Rolle. Es sei denn, irgendwo ist der Pfad hardcoded enthalten. Das wäre natürlich fatal.

  • Bitte nur den aktuellen Installer von Entware nutzen http://bin.entware.net/other/Entware_1.00std.qpkg und Entware-NG entfernen.


    Das ist darum wichtig, weil das Skript über Entware einige notwendige Pakete nachinstalliert.


    Ggf. diese manuell installieren


    opkg install grep sed procps-ng procps-ng-w bc bash coreutils coreutils-cat coreutils-tail coreutils-ln coreutils-mkdir

  • Hallo miteinander, da Pyload es nicht gebacken bekommt "ddl.to" hinzuzufügen musste ich auf Jdownloader ausweichen.

    Die Installation hat über das Qnap Club Center einwandfrei funktioniert...Der Rest wurde mit SSH erledigt...


    Eigentlich läuft soweit alles, außer der Downloadpfad...
    Standartmäßig ist dieser "/homes/admin/Downloads"...

    Da ich eine andere Menüstruktur habe, möchte ich dies in einem anderen Ordner... "/Multimedia/Downloads"

    Sobald ich den Pfad ändere, kommt bei jedem Download Skipped - Disked is Full...

    Habe in den Settings auch den Haken schon entfernt...Weiß jemand weiter?


    LG

  • Hört sich irgendwie an, als wenn es an Berechtigungen liegen könnte? Ich kann mir vorstellen, dass der Downloader nicht direkt ausgeben kann, wenn kein Schreibberechtigungen vorhanden sind? Frag mich aber bitte nicht, wie die Berechtigungen gesetzt sein müssen

  • Ich habe diese Version installiert. Er schreibt mir immer in den System Log, dass ich doch bitte den web server aktivieren solle. Kann man das deaktiveren? Er funktioniert auch ohne web server via my.jdownloader

  • Kann mir bitte einer erklären warum ich jdownloader jedesmal nach einem Firmware Update neu installieren muss. Das Programm ist auf der NAS noch drauf aber ich kann es nicht starten und darauf zugreifen. Somit installier ich es immer neu. Gibt es da eine Lösung?


    Danke

  • ich nutze es als docker image, was so super läuft bei mir. Das startet dann auch nach jedem Neustart ohne Probleme wieder. Von daher kann ich dir nicht helfen mit der QNAP-App, aber ich kann es dir nur so empfehlen

  • Habs auch als Dockercontainer am laufen. Funktioniert bisher problemlos. Die downloads kann ich dann über die App von Handy aus starten.

  • Also ich bin mit dem Thema Docker selbst noch recht unerfahren, habe es aber hinbekommen.

    Da ich aktuell in Urlaubs-Vorbereitungsstress bin kann ich dir gerne nach Weihnachten behilflich sein, wenn ich aus Schweden wieder zurück bin. Vielleicht findet sich ja jemand anderes hier, der das früher macht, aber sonst helfe ich dir gerne, soweit ich kann

  • hey
    bin komplett neu hier und arbeite mich gerade in meinen ersten NAS ein.
    Und bin dabei auf eine für mich dann interessante Zusatzfunktion gestoßen.
    Ich wollte gerne den JDownloader 2 als sagen wir mal "Komplettinstallation" und alleine Über den NAS laufen lassen.
    Also ein mal die ganzen Einstellungen vornehmen und anschließend läuft nur noch der NAS.


    Ich hab jetzt von JD2 die JAVA Datei benutzt und es ist auf dem NAS auch im App-Center zu finden.

    Jedoch verlinkt er nur auf die Webseite my.jdownloader.org, auf der kann ich weder die 2 für meine zwecke benötigten Skripte eintragen noch kann ich vernünftig den Proxy einstellen.


    Des weiteren hat er sich jetzt schon mit den Programm auf den Desktop verknüpft das ich diese nun anscheinend immer starten muss damit überhaupt was passiert.


    Wo habe ich den Fehler gemacht oder was vergessen?
    Oder geht das nur einfach nicht so wie ich mir das vorgestellt habe? :S:?:

  • danke erstmal für die Antwort.

    hab leider jetzt erst wieder zeit gefunden mit dem NAS ein bisschen zu "Spielen" und meine Freizeit damit aus zu gestalten ....
    Und daher auch erst jetzt wieder ins Forum geschaut.


    Erstmal eine Super Anleitung
    Jedoch kommt bei mir genau wie bei ROb87 der Fehler:

    Code
    1. standard_init_linux.go:185: exec user process caused "exec format error


    Der sich wohl aus dem

    "Annapurna Labs Alpine AL314 Quad-core ARM Cortex-A15 CPU"
    ableiten lässt

  • Hallo,


    ich habe jdownloader nach der Anleitung erfolgreich installiert. Da ich inzwischen aber auch einen Container mit jdownloader laufen habe würde ich gerne jdownloader wieder deinstallieren. Wie mache ich das?


    VG


    Daniel