Raid Festplatte klonen

  • Hab jetzt nichts gefunden, daß dieses Thema bzw. meine Frage beantwortet.


    Ich habe hier ein Qnap TS-859 Pro+ mit 8 Festplatten die jeweils 3 TB groß sind.
    Das ganze ist in einem RAID 6 Verbund. Nachdem beim Kauf schon die Platten verbaut waren, handelt es sich um 8 x die selben (Hitachi HDS723030ALA640)
    Nun habe ich mir gedacht, daß ich nach ner Zeit von 2 - 3 Jahren mal Platten vorsorglich tausche um ein desaster vorzubeugen. Da ja bekanntlich das so ist, wenn eine stirbt, alle dran sind.
    Nachdem meine Platten alle ja noch funktional sind, stellt sich mir folgende Frage.
    Wenn ich mir nun 2 Platten von WD Kaufe (Western Digital WD Red WD30EFRX) und eine Platte ausbaue wenn das Qnap aus ist, die Platte auf die WD klone und dann das Qnap einschalte, wird dann dennoch das RAID wieder hergestellt, oder erkennt er das hier die richtigen Daten vorhanden sind?!


    Danke schon mal im voraus.

  • Ich kenne zu dieser Vorgehensweise keinen einzigen Erfahrungsbericht hier im Forum.


    Daher lässt sich von mir die Frage nur theoretisch-spekulativ beantworten: Das Klonprogramm muss die Sektoren der Platte physikalisch bitgenau klonen, dann sollte die QNAP nicht merken, dass sie einen Klon vorgesetzt bekommt und das RAID wieder durchstarten. Sollte der Klon diese Voraussetzung nicht erfüllen, wird die QNAP wahrscheinlich "meckern" und das RAID auf degraded setzen. Dann müsste die HDD gelöscht/neuformatiert werden und über einen normalen Rebuild wieder eingebunden werden.


    GLG GBD

  • Ich hätte von der Platte auf jedenfall eine 1:1 kopie mittels dd oder einem klonprogram erstellt, das sektorweise kopiert.
    Naja, ausprobieren kann ich es ja mal ;-)
    Aber es könnte ja theoretisch sein, daß das RAID merkt das da ne Platte anderem Hersteller vorhanden ist und ihm dann egal ist, was auf der Platte drauf ist.

  • Hallo,
    hier stellt sich aber auch die Frage, ob es denn wirklich sinnvoll ist, 8 funktionsfaehige Platten auszubauen und zu ersetzen.
    Ich persoenlich wuerde die solange laufen lassen, bis sie dir wegsterben. Du hast schliesslich erstmal ein RAID6, dass im Normalfall den Ausfall von ein bis zwei Platten verkraften kann.
    Ausserdem solltest du auch immer ein aktuelles Backup zur Hand haben, falls mal etwas schiefgehen sollte, denn ein RAID kann ein Backup niemals ersetzen.

  • Da es diesbezüglich hier noch keine Erfahrungen gibt, würde ich das ganze mal als Herrausforderung begreifen. :D
    Also Platten besorgen, Backup aktualisieren und her mit Deinen Ergebnissen. :thumb:

  • Zitat von "kenney"

    Aber es könnte ja theoretisch sein, daß das RAID merkt das da ne Platte anderem Hersteller vorhanden ist und ihm dann egal ist, was auf der Platte drauf ist.


    Das ist eine gute Frage, die ich leider nicht beantworten kann. Ich würde vermuten, dass das RAID der QNAP die Platte anhand der darauf befindlichen logischen Informationen identifiziert, eine Identifikation über eine individuelle ID würde ich aber auch nicht ausschliessen wollen, weil QNAP an anderen Stellen (z.B. optional beim Backupprogramm "externe Sicherung") mit genau einer solchen Erkennung arbeitet.


    GLG GBD

  • Zitat von "TobiasK"


    Ausserdem solltest du auch immer ein aktuelles Backup zur Hand haben, falls mal etwas schiefgehen sollte, denn ein RAID kann ein Backup niemals ersetzen.


    Das ist mir bewußt. Ein komplettes Backup gibt es nicht von dem Qnap. Die wichtigsten Daten jedoch sind gesichert.
    Aktuell bin ich nach einem zweiten Qnap drann, daß dann eben als "Datengrab" dient ;-)
    Wobei ich hier noch unsicher bin ob ich mir wieder 8 x 3 TB nehme, oder lieber ein 6er mit 4 TB


    Mir ist auch bewußt das bei einem RAID 6 2 Platten sterben können, aber aus mehrfacher Erfahrung kann ich sagen, wenn eine stirbt dann kannst du regelrecht zusehen wie die anderen kurz darauf ebenfalls den Geist aufgeben. Das hab ich schon mehrfach Live erlebt.
    Mir geht es einfach nur darum die "Sicherheit" eines Datenverlustes zu verkleineren.


    Zitat von "biboca"

    Da es diesbezüglich hier noch keine Erfahrungen gibt, würde ich das ganze mal als Herrausforderung begreifen. :D
    Also Platten besorgen, Backup aktualisieren und her mit Deinen Ergebnissen. :thumb:


    Also bisher hatte ich das auch vor. Muß nur mal sehen das ich 2 Platten bestelle.
    Wenn ich das dann mal gemacht habe, dann werde ich auf alle Fälle berichten.
    Wollte mich halt vorher mal informieren, wäre ja möglich gewesen, daß dies schon mal jemand gemacht hat

  • Hab mal Qnap direkt gefragt, hier mal die Antwort:


    Sehr geehrter Kunde,


    vielen Dank für Ihr Supportanfrage.


    Das ist möglich, jedoch nur dann wenn das Volumen nicht verschlüsselt wurde über
    die Oberfläche.
    Ansonsten sollte dies kein Problem darstellen, das Volumen zu klonen.



    Na dann, steht ja einem Versuch nichts mehr im Weg ;-)

  • So.


    Am Donnerstag habe ich mir nun 2 3TB von WD gekauft.
    Zum klonen habe ich die "Lindy USB 3.0 Docking & Cloning Station 43112" genommen.


    Und es hat geklappt, alles noch da und kein Rebuild :-)

  • Zitat von "kenney"

    Zum klonen habe ich die "Lindy USB 3.0 Docking & Cloning Station 43112" genommen.


    Spannend! Das ist der erste Erfahrungsbericht über einen erfolgreichen Klonprozess, den ich aus diesem Forum kenne. :thumb:


    Könntest Du bitte mal beschreiben, was genau auf der zu klonenden Platte drauf war, wie genau das Klonen mit dieser Station durchgeführt werden kann und wie lange dieser Klonprozess gedauert hat ? Kann man das Gerät auch versehentlich falsch bedienen und die leere Platte auf die volle klonen ?


    Diese Details würden mich sehr interessieren.


    Danke und GLG
    GBD

  • Hallo


    Also ich werde mal alles berichten.


    Zuerst wollte ich die Platte mittels Acronis / Clonezilla spiegeln. Dies ging aber nicht, da er mir die Platte immer ausgegraut bzw. nicht angezeigt hatte. Liegt wohl am Format der Platte, bei Acronis stand da GBT drinnen.
    Nachdem ich mich informiert hatte, habe ich mir die Clonestation von Lindy & Inateck zum testen gekauft.
    Hoffe es geht klar das ich hier mal die Links Poste.


    Lindy -->> (Lindy 43112v2) Werbung entfernt, siehe Forenregeln!
    Handbuch -->> http://www.lindy.de/$WS/ld0101/websale8_shop-ld0101/produkte/medien/manuals/43112v2.pdf


    Inateck -->> (Inateck FDU3C-2) Werbung entfernt, siehe Forenregeln!



    Allerdings stand bei der Inateck dann in der Beschreibung, daß man keine Platten klonen kann die gleich groß sind und habe es daher nicht getestet.
    Angeblich soll es laut den Rezesionen dennoch gehen. Steht auch bei den Meinungen bei Inateck mit drinn.
    Werde ich mal bei Gelegenheit testen ;-)


    Ich habe das Qnap ausgeschaltet. Dort sind 8 Platten im RAID 6 Verbund. Habe erst eine Platte ausgebaut und mit dem Lindy Teil geklont.
    Also man kann sicherlich die Platten vertauschen, aber auf den Schächten steht sehr deutlich TARGET / SOURCE drauf. Naja, sollte also jedem klar sein, was wohin kommt :)
    Also Platten in die Schächte, Power ein, warten bis Platten hochgelaufen sind. Dann muß man nur noch ca 5sec den Cloneknopf drücken und dann fängt er an. Der Clonevorgang wird durch eine blinkente blaue LED angezeigt, die dann dauerleuchtet wenn es fertig ist.
    Der Vorgang dauert ca 7 - 8 Std bei meinen 3 TB Platten.
    Danach hab ich dann die geklonte Platte eingebaut und das NAS hochgefahren. Dann über den Webbrowser unter Datenträger eben nachgesehen, was er dort schreibt. Aber außer das nun ne andere Platte im System erscheint, hat sich nichts verändert.


    Aber was ich jedenfalls sagen muß ist, daß die Platten in der Station extrem warm werden. Hatte dann 55° - 60°. Das war mir dann zu viel und hab mir dann nen Ventilator geholt. Das sollte man also vorher bedenken!

    2 Mal editiert, zuletzt von GorillaBD () aus folgendem Grund: Werbung entfernt, siehe Forenregeln.

  • Vielen Dank für Deinen Bericht! :thumb:


    Die hohe Kopiergeschwindigkeit wundert mich, von anderen Geräten dieser Art habe ich in Sachen Zuverlässigkeit und Kopiergeschwindigkeit diesbezüglich nichts Gutes gelesen. Das Temperaturthema wird bei allen Geräten dieser ART so berichtet und ist auch verständlich, wenn beide Platten über Stunden so "Vollgas" laufen. Ich halte das für nur über einen so kurzen Zeitraum für unkritisch, dauerhaft sollte eine Platte natürlich nicht so warm laufengelassen werden.


    Ich habe hier noch Orico-Quickports mit auch einer solchen Klonfunktion stehen, die muss ich dann doch glatt auch mal testen.


    GLG GBD


    P.S.
    Die Links zu den Shopseiten musste ich entfernen, weil dies gegen unsere Forenregeln ist. Die Mitleser können die Geräte anhand der Typenbezeichnungen, die ich stattdessen eingesetzt habe, bei Interesse ja leicht im Netz selbst auffinden.

  • Das die Werbung entfernt wurde ist nicht schlimm.


    Was du bei der Clonestation beachten mußt ist, daß ältere keine Laufwerke größer als 2 TB unterstützen. Das hat mir ein Arbeitskollege berichtet.
    Steht ab und zu auch bei den Rezesionen mit dabei.
    Somit mußt du da bei deiner mal nachprüfen was hier möglich ist.

  • Hallo zusammen,

    ich hole den alten Thread nochmal hoch, da ich ein ähnliches Problem habe.

    Auf meiner TS-110 läuft mein CAO Faktura. Die Platte ist mit abnormal gekennzeichnet - läuft aber noch.

    Alle bisherigen Versuche die zu Klonen sind gescheitert: Acronis, EaseUse und über eine Fideco Clonestation. Ist zwar alles drauf, aber die NAS erkennt die jedesmal als NEUE Platte.


    OK dachte ich...machst halt alles neu. Datensicherung hab ich ja.

    Problem ist Optware IPKG gibt es wohl nicht mehr unter 4.2.6

    Alternative gesucht- unter Entware kein SQL 4 zu finden.


    Jemand eine Idee zum Klonen, oder wie ich nach nach einer Neuinstallation SQL 4 drauf bekomme?

    Gruß

  • Erst mal Hallo.


    Mach ein neues Thema auf, diese hier wurde bereits als beantwortet "abgehakt" und da lesen/antworten nicht mehr alle User ...