[Web-GUI] Internet-Radio aufzeichnen: Streamripper

  • [NAS Typ:] arm (eventuell andere)
    [Firmware:] ab 3.7.0
    [Getestet:] ja, mit TS-212


    Das einfache Streamripper Admin GUI stellt per Browser folgende Funktionen zur Verfuegung:
    - Anlegen und Verwalten von Shoutcast Senderdaten
    - Starten von Streamripper Aufnahmen mit vorgegebener Laufzeit oder endlos
    - Abbrechen von laufenden Streamripper Aufnahmen


    Nicht unterstuetzt werden Aufnahmen zu einem bestimmten Zeitpunkt oder automatisch wiederholte Aufnahmen.




    Voraussetzungen:
    Nutzerseitig:
    Web-Browser mit Javascript Unterstuetzung


    QNAP:
    Apache mit PHP
    Datenbankserver MySQL
    Streamripper muss installiert sein, siehe QNAP Wiki:
    http://wiki.qnap.com/w/index.p…e=Streamripper&setlang=de


    Bei der Installation:
    ein wenig Telnet/SSH-Kenntnisse


    Das Paket basiert auf den php-Scripts von Pio435 (aus dem dt. Synology-Forum).
    Alle Anpassungen und Erweiterungen von phys1 (QNAP-Forum).

  • soweit ich weiß hab ich alles genau nach der anleitung gemacht, aber trotzdem kommt beim aufruf im browser nix.


    kann mir jmd hierbei helfen bitte?

  • Hallo,


    stimmt der Pfad zum Webverzeichnis: /share/Qweb? Auf manchen Systemen lautet der anders, z.B. /share/Web.
    Hast du die Datei /share/Qweb/streamripper/command/config/usersettings.php mit den korrekten Einstellungen editiert?


    Erscheint beim Browseraufruf eine Fehlermeldung (wie lautet sie) oder nur eine weiße Seite?
    Wenns nur eine weiße Seite ist, hängt das php Script. Poste mal die usersettings.php (MySQL Passwort kannst du ja rausnehmen).


    Gruß
    phys1

  • hierhin habe ich es entpackt auf meinen TS 212
    /share/MD0_DATA/Sonstiges/StreamripperSimpleGUI/streamripper


    dann in der usersettings.php in
    /share/MD0_DATA/Sonstiges/StreamripperSimpleGUI/streamripper/command/config
    <?php
    $dbHost = "NAS";
    $dbUser = "root";
    $dbPass = "xxx";
    $dbName = "streamripper";
    $recPath = "/share/MD0_DATA/Musik/Streamripper";
    $sripExec = "/opt/bin/streamripper";
    $defParameters="-o larger -T -u \"WAFA/1.2.10 (Linux; Android 4.1; Winamp) Replicant/1.0\" --xs2 --xs-offset=500 --xs-padding=1000:500 --xs-search-window=6000:6000 --xs-silence-length=1000 --codeset-filesys=UTF-8";
    $sripMaxProcs=6;
    ?>


    beim dbpass bin ich mir nicht sicher was da rein soll, hab schon allees mögliche durch


    als fehlermeldung kommt beim aufruf von 192.168.0.5/streamripper


    Not Found
    The requested URL /streamripper was not found on this server.
    Apache Server at 192.168.0.5 Port 80

  • Hallo,


    per Konsole (Putty SSH oder ähnliches) den Link zum Web share erstellen:
    ln -sf /share/MD0_DATA/Sonstiges/StreamripperSimpleGUI/streamripper /share/MD0_DATA/Qweb/streamripper


    In der usersettings.php sollte stehen:
    $dbHost = "localhost";
    $dbUser = "root";
    $dbPass = "admin";
    sofern man das MySQL Passwort nicht geändert hat (was man eigentlich machen sollte!)
    $dbHost muss nur geändert werden, wenn der Apache Webserver und der MySQL Server auf verschiedenen Machinen laufen, was aber nur sein kann wenn man mehrere NAS hat.
    $recPath = "/share/MD0_DATA/Musik/Streamripper"; muss existieren und der httpdusr muss Schreibrechte haben!


    Dann sollte es funktionieren.


    Ich werden das Paket Ende Januar als QPKG herausgeben. Dann muss man sich nicht mehr mit der Konfiguration per Konsole herumschlagen.
    Dafür suche ich noch Beta-Tester. Bei Interesse PM an mich.


    Viele Grüße
    phys1

  • habs nochmal installiert, aber nicht in Qweb das gibts bei mir nicht, sondern in Web


    jetzt kommt schonmal das streamripper webif, wenn ich nun aber oben einen sender zufügen will
    ->ID
    Keine Verbindung zum Datenbankserver: Access denied for user 'root' localhost (using password: YES)


    der httpdusr existiert nicht bei mir, muß ich den noch anlegen? wenn ja, wo muß er rechte haben

  • Sieht doch schon mal nicht schlecht aus, der MySQL Server hat lediglich wegen falschem Passwort den Zugriff verweigert.


    Das default Passwort ist admin, also deshalb
    $dbPass = "admin";
    in die usersettings.php eintragen. (Es sei denn, du hast bereits ein anderes Passwort vergeben.)


    Den httpdusr musst du nicht anlegen. Das ist das Benutzerkonto, unter dem der Apache Web Server normalerweise läuft.
    Da der Webserver den streamripper startet, muss dieses Benutzerkonto Schreibrechte in dem Ordner haben, wo die Musik aufgezeichnet wird.
    Sonst scheitert die Aufnahme wegen fehlender Schreibrechte.


    Das beste ist also einen Share in der QNAP Verwaltung anzulegen (z.B. Musik) und jedermann Schreibrechte zuzuteilen.
    Und den Share in der usersettings.php entsprechend eintragen, z.B.:
    $recPath = "/share/MD0_DATA/Musik/Streamripper";
    Das Unterverzeichnis "Streamripper" legt der streamripper dann selbst an, nur der Share muss existieren.


    Gruß
    phys1

  • hetzt kann ich sender eintragen, hatte passwort kuddelmuddel hier


    aber auswählen kann ich ihn nicht


    edit:
    im opera ist das feld zu klein zum auswählen. wird nicht richtig dargestellt


    edit 2:
    ich nutze standardmäßig seitengröße 120% - mit 100 klappt die darstellung.
    da müßte man mal die php anpassen

  • Wie sieht es denn auf der Seite 'Sendertabelle' aus? Werden da die bereits definierten Sender in den Listboxen für 'Senderdaten updaten' oder 'Sender löschen' angezeigt? Die Hauptseite muss man neu laden, damit gerade erst definierte Sender das erste mal angezeigt werden.
    Opera habe ich nicht getestet, im Firefox und IE8 wurden die Listboxen mit den Sendern korrekt angezeigt.


    Viele Grüße
    phys1

  • Hallo,


    mein Streamripper Script verwendet zwar JavaScript, aber weder 'tools.js' noch 'document.write(ERR401_TITLE)'.
    Das muss also 'ne Wechselwirkung mit etwas anderem sein. Friday, hast Du eventuell die QNAP Firmware aktualisiert oder im Browser Einstellungen geändert?


    Möchte auch noch ankündigen, dass ich das Script jetzt als QPKG Paket herausgebe!
    Dazu suche ich noch ein oder zwei Beta-Tester, am besten mit Intel CPU (da ich 'ne ARM Maschine habe).


    Viele Grüße
    phys1

  • die firmware habe ich nicht erneuert,


    ich habe lediglich SABnzbdplus sowie auch NZBget auf dem qnap installiert.


    beide habe ich aber schon testhalber deaktiviert.


    --- EDIT ---


    es läuft wieder


    hatte vergessen den webserver wieder einzuschalten

    Einmal editiert, zuletzt von GorillaBD () aus folgendem Grund: Doppelte Beiträge vermeiden, siehe Forenregeln!