NFS-Shares nach Standby falsch verbunden

  • Hallo zusammen!


    Ich habe ein merkwürdiges Problem mit den NFS-Shares meines TS-419+ (Firmware 3.71): Jedes mal, wenn mein (K)ubuntu-Rechner wieder auf dem Ruhezustand aufwacht, sind die über /etc/fstab gemounteten Shares falsch verbunden. ich lande jedesmal im Multimedia-verzeichnis.


    Hier meine fstab

    Code
    1. linuxnas:/share/MD0_DATA/Multimedia /nfs/Multimedia nfs defaults 0 0 linuxnas:/share/MD0_DATA/Download /nfs/Download nfs defaults 0 0 linuxnas:/share/MD0_DATA/Public /nfs/Public nfs defaults 0 0 linuxnas:/share/MD0_DATA/backup /nfs/backup nfs defaults 0 0 linuxnas:/share/MD0_DATA/olliko /nfs/olliko nfs defaults 0 0


    Und hier die Ausgabe von exportfs des TS-419+

    Code
    1. [~] # exportfs/share/MD0_DATA/Download <world>/share/MD0_DATA/Multimedia <world>/share/MD0_DATA/Public <world>/share/MD0_DATA/backup <world>/share/MD0_DATA/hatte <world>/share/MD0_DATA/olliko <world>


    Laut df sind jedoch alle shares korrekt gemountet:


    Hat jemand eine Idee, an was das liegen könnte? Ein workaround wäre eventuell, das man die Ubuntu-Kiste anweist, beim Aufwachen die Shares auszuhängen und wieder frisch einzuhängen. Die frage ist,wie....


    Schöne Grüße, Oliver

  • Ich habe die Lösung selbst gefunden - vielleicht hilft es jemanden weiter.


    Qnap scheint NFS etwas anders zu konfigurieren als standardmässig unter Linux üblich.
    Ich habe mir die Startscripte angesehen und dort den Aufruf eines Binaries gefunden, das wohl bei jedem Start des Dienstes die /etc/exports neu generiert. Das geschieht vermutlich auf Basis der smb.conf, in der die Samba (Windows)-Shares definiert sind. Es muss aber noch etwas anderes verbogen werden, denn ein Aufruf von "showmount -e rechnername" auf dem Clientrechner fördert folgende Share-Liste zutage



    Der Pfad aus der /etc/exports wird aus dem Sharenamen also irgendwie entfernt.



    Lange Rede, kurzer Sinn: in die /etc/fstab gehören nur die reinen Sharenamen ( z.B. "linuxnas:/Public /nfs/Public nfs defaults,bg 0 0"), wie sie im Webinterface des Qnap-Nas definiert wurden. Dann funktioniert es tadellos.