Load Cylcle Problem

  • Du mußt noch den / vor share eintippen
    also
    /share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sda


    Hast du
    chmod +x /tmp/config/autorun.sh
    gemacht, damit das shellscript ausführbarist? Sonst kann man das nicht ausführen

  • wenn ich chmod +x /tmp/config/autorun.sh teste ich ,ob die datei ausführbar istrichtig?


    Wenn ich das mache, passiert nichts. Ich kann danach einfach in der nächsten Zeile der Console weiter tippen. Heißt dass, es funktioniert alles richtig?


    edit: Es lag wohl tatsächlich an dem fehlenden "/" vor dem share. Ich habe das NAS einmal heruntergefahren und danach mit hdparm den Status des APM gecheckt. Ergebnis "APM = Off". 8-)

  • Also ich habe das Tutorial befolgt, aber irgendwie scheint es mir so, als wenn sich nur der Load Cycle der 1. Platte (3* 3TB Seagate ST3000DM001 im Raid 5) nicht mehr ändert, der der andern aber schon.
    Gilt der Befehl nur für eine Platte?


    Kann bitte jemand ein kurzes Tur für die Befehle machen, die man braucht um das Script einzubinden (inkl. Mounten, etc.), der das ganze auch nach nen Neustart beibehält? Kenne mich mit Linux garnicht aus.


    Danke im vorraus!


    Mfg KAMPI

  • Ja, der Befehl gilt nur für eine Platte


    Du mußt die hdparm Zeile in der autorun.sh vier mal einbauen und als interface jeweils die Platten /dev/sda, /dev/sdb, /dev/sdc, /dev/sdd einbauen


    Die autorun.sh und das mounten ansonsten wie im dem tutorial beschrieben machen


    Und vorher die neues Version von hdparm über opgk installieren


    Was hast du denn bisher gemacht, so daß es bei einer Platte tut? Klappt das bei dir auch schon, wenn du das NAS richtig ausschaltest?


    Meine autorun.sh sieht so aus


    Shell-Script
    1. #!/bin/sh/share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sda


    deine müßte dann so aussehen

    Shell-Script
    1. #!/bin/sh/share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sda/share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sdb/share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sdc/share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm -B255 /dev/sdd


    vorher mit

    Code
    1. mount /dev/mtdblock5 /tmp/config

    den Config Bereich für autorun.sh mounten
    dann die autorun.sh mit obigem Inhalt nach /tmp/config kopieren
    dann wieder
    umount /dev/mtdblock5
    eingeben und neu starten


    Ich hänge dir die autorun.sh mal dran, die alle vier hdparm Zeilen beinhaltet

    Dateien

    • autorun.rar

      (165 Byte, 45 Mal heruntergeladen, zuletzt: )

    Einmal editiert, zuletzt von anudanan ()

  • Super, vielen Dank :)
    Mit deiner Beschreibung hat alles geklappt und wie es aussieht, funktioniert es auch.


    VG KAMPI

  • Hallo zusammen,
    habe noch eine kleine Frage.
    Mit welchen Befehl kann ich denn schauen, ob das APM auch wirklich ausgeschaltet ist und somit das Script funktioniert hat? Kenne nur "hdparm -B255 /dev/sda". Damit schalte ich es ja aber aus und kann nicht erkennen, ob es schon vorher durch das Script ausgeschaltet worden war.


    Danke für eure Antwort!


    Mfg KAMPI

  • einfach hdparm -B /dev/sda, also ohne Zahl dahinter
    du must aber das richtige hdparm nehmen, also das nächträglich installierte, was auch im autorun.sh aufgerufen wird

  • Danke für deine Antwort.
    Also irgendwie scheint das mit dem Script nicht zu klappen. Das APM Level steht bei allen Platten auf 128. Komisch. Irgendeine Idee, woran das liegen könnte? Wenn ich den Mount mache, ist die Datei da und ich der Inhalt ist so, wie im Beispiel (nur mit 3 Platten).


    Mfg KAMPI

  • Wenn ich das Script manuell ausführe kommt folgende Meldung:


    [/tmp/config] # ./autorun.sh
    ./autorun.sh: line 2: /share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm: No such file or directory
    ./autorun.sh: line 3: /share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm: No such file or directory
    ./autorun.sh: line 4: /share/HDA_DATA/.qpkg/Optware/sbin/hdparm-hdparm: No such file or directory


    Wenn ich per WinSCP ins Verzeichniss /share/HDA_DATA schaue, ist das leer. OptWare habe ich aber über das QPKG Center geladen, installiert und aktiviert.
    Warum ist das dann nicht da?


    Danke für eure Antworten!


    Mfg KAMPI

  • Funktioniert das Abschalten des APM auch für WD Scorpio blue (2.5") Platten ?
    Ich hab das mal mit folgenden Platten versucht, aber nur eine Fehlermeldung zurück bekommen :


    WD5000BEVT (500GB)
    WD10JPVT (1TB)


    Funktionsaufruf mit : hdparm-hdparm -B255 /dev/sda (und natürlich auch mit sdb,sdc und sdd)
    Fehlermeldung :


    Code
    1. setting Advanced Power Management level to disabled
    2. SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00
    3. 00 00 00 00 00 00 00 00
    4. SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00
    5. APM_level = not supported


    Es handelt sich bei dem NAS um das SS-439 Pro mit Firmware 3.6.0 Build 0210T


    Das sieht fast danach aus, als würden die 2.5" HDDs mit den Load_Cycle_counter Problem leben müssen .
    Oder hat es jemand geschaft, dies für die 2.5" Platten in den Griff zu bekommen.


    Btw, die WD10JPVT mit 1TB macht in dem SS-439 Probleme (Ich weiss, ist nicht auf der Kompatibilitätsliste, aber da ist keine 1TB 2.5" HDD) :
    1) Load_Cycle_counter Problem
    2) Der Zugriff auf die Laufwerkselektronik ist langsam, sehr schön zu sehen beim Auslesen der HDD S.M.A.R.T. Parameter. Dies dauert
    für die WD10JPVT um ein vielfaches länger als für die gleichzeitig (RAID5 mit 4 Platten) verbauten WD5000BEVT
    3) Der S.M.A.R.T. Festplatten Test wird mit einem Read failure beendet. Sowohl im Rapid als auch im Complete Test Modus


    Performance der Platte konnte ich so noch nicht testen, das rebuild des RAID5 mit rund 1.3 TB Daten war in 3 h 14 m beendet.


    Ich denke Ich werde die Platte wieder zurück schicken, hat evtl. jemand mit einer anderen 2.5" HDD mit 1TB gute Erfahrung im QNAP machen können ?


    Gruß
    Pumlux

    Einmal editiert, zuletzt von bladekiller () aus folgendem Grund: Code Block hinzugefügt.

  • Ja habe ich. Benutze auch immer hdparm-hdparm. Wenn ich den Befehl so aufrufe, dann funzt es ja auch. Nur er findet das optware nicht. Warum muss man im Script überhaupt den Pfad angeben? Weil wenn ich mich per SSH einlogge, brauche ich ja nur den Befehl "hdparm-hadparm..." eingeben.


    Mfg KAMPI


    P.S. Habe das Install gerade noch mal aufgerufen. Scheint wirklich schon dagewesen zu sein:


    Code
    1. [~] # ipkg install hdparm
    2. Package hdparm (9.39-1) installed in root is up to date.
    3. Nothing to be done
    4. Successfully terminated

    .

    Einmal editiert, zuletzt von bladekiller () aus folgendem Grund: Volltextzitat entfernt! Code Block hinzugefügt.

  • ich hatte bei mir den Pfad angegeben, da ich nicht wußte, ob das beim Hochfahren alles automatisch gefunden wird


    Du kannst ja mal schauen, wo dein hdparm-hdparm liegt im filesystem


    am besten gehst du ins telnet und machst


    cd /
    find . -name "hdparm-hdparm"


    dann siehst du, wo bei deinem System der hdparm-hdparm Befehl hin installiert wurder.


    diesen Pfad würde ich dann in die autorun.sh nutzen, damit es auch beim booten klappt

  • Hi,
    danke für deine Antowort.
    Mit deinem "find" Befehl hat er komischerweise nichts gefunden, obwohl ich hdparm-hdparm ja ausführen kann. Mit dem "Which" befehl hat er es gefunden. Es liegt in "\opt\sbin". Habe das nun in die Autorun.sh geschrieben und es scheint damit zu klappen. Keine Ahnung, warum es bei mir in desem Verzeichniss ist.


    Danke für eure Hilfen!!


    Mfg KAMPI

  • Zitat

    Mit deinem "find" Befehl hat er komischerweise nichts gefunden


    Das wird daran liegen, weil du das

    Code
    1. cd /

    vorab vergessen hast ;)

  • Hat jemand dafür vllt. mittlerweile eine Lösung ?


    Zitat

    setting Advanced Power Management level to disabled
    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00
    00 00 00 00 00 00 00 00
    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00
    APM_level = not supported


    Wollte APM bei meinen Seagate ST3000DM001 deaktivieren, damit der Load Cycle Counter nicht so hoch läuft aber bekomme die oben aufgeführte Fehlermeldung.


    hdparm liegt in der Version 9.39 vor

  • Hallo,


    habe das auch das Problem, dass der Load_Cycle_Count permanent hochzählt.


    Mit den Anweisungen hier hat das mit der autorun.sh leider nicht geklappt. Ich hab die Datei erstellt, aber sie wird irgendwie nicht ausgeführt ...??


    Wäre jemand nochmal so nett, dass Schritt für Schritt nochmal zu erklären?


    Thx!!


    -------------------------
    OK, hab's hinbekommen. :D


    Die autorun.sh muss so lauten:

    Shell-Script
    1. #!/bin/sh
    2. /opt/sbin/hdparm-hdparm -B255 /dev/sda
    3. /opt/sbin/hdparm-hdparm -B255 /dev/sdb
    4. /opt/sbin/hdparm-hdparm -B255 /dev/sdc
    5. /opt/sbin/hdparm-hdparm -B255 /dev/sdd