Neuer iTunes Server: Airplay (forked-daapd) QPKG

  • Moin!


    Da es QNAP leider immer noch nicht geschafft hat, den uralten iTunes Server zu aktualisieren, hat sich auf meinen Vorschlag hin internaut19 im englischen Forum - ein wirklich genialer Typ! - dem ganzen angenommen und innerhalb nur etwa einer Woche, auch dank der grossartigen Vorarbeit von ADoko, das ganze als QPKG hingekriegt. :)


    Funktioniert bei mir einwandfrei, iTunes erkennt den neuen Airplay iTunes Server sofort. Und das genialste daran: Ich kann auf dem iPhone oder iPad mit der Remote App von Apple alle Musik von meinem NAS per Airplay direkt an mein Apple TV (ATV2) senden und somit auf meiner - über einen AV Receiver - angeschlossenen 5.1 Anlage hören! *frohlock* :D


    Der Vorteil der Remote App ist, dass diese gut und schnell funktioniert aber vor allem dass sie IMHO deutlich komfortabler ist - bezüglich Musik - als Apps wie Qmobile oder diverse UPnP Clients. Halt wie man es vom iPod Player im iPhone gewohnt ist, einfache Navigation anhand Interpret, Alben, Komponist, Genre, etc. Aber der absolute Hammer: Eine richtig gute SUCHFUNKTION wo ich einfach etwas eingeben kann und dann wird der gewünschte Titel in meiner (tendenziell chaotischen) MP3 Sammlung in wenigen Sekunden gefunden! :mrgreen: Ihr glaubt gar nicht wie lange ich darauf gewartet habe, endlich funktioniert alles so wie es soll - mit meiner bereits existenten Infrastruktur, ohne dass ich ein weiteres Produkt kaufen musste. Die Daten liegen auf dem NAS, das iPhone dient als Fernbedienung und ATV ist der Empfänger. Eine lokale Ausgabe ist mit der App nicht möglich.


    Info am Rande: Bisher wurde erst v1 des proprietären Apple AirPlay Protokolls (d.h. eigentlich der Vorgänger AirTunes, welches nur Musik streamen konnte) reverse engineered. Daher unterstützt auch forked-daapd und somit das Airplay QPKG nur das Streamen von Musik - nicht aber Bilder und Videos (was erst mit einer späteren AirPlay Version dazukam)! Ob und wann sich dies ändern wird, ist derzeit nicht abzusehen.


    Zwei QPKGs sind dazu notwendig.


    1. Avahi: http://forum.qnap.com/viewtopic.php?f=128&t=47748. Ersetzt den integrierten Bonjour Service (mDNSResponderPosix) und übernimmt automatisch dessen Funktion/Konfiguration. Muss zwingend zuerst installiert werden.
    2. Airplay (forked-daapd): http://forum.qnap.com/viewtopic.php?f=128&t=49487. Ersetzt den integrierten iTunes Server (muss vor der Installation aktiviert werden!) und übernimmt dessen Funktion/Konfiguration.


    Alle weiteren Infos auf den verlinkten Seiten, bitte dort alles ganz genau durchlesen! Fragen am besten auch direkt dort stellen.


    Viel Spass! :)

    Einmal editiert, zuletzt von IamQ ()

  • Moin,


    boooaaaahhh das klingt ja geil... :D:D


    Werde ich gleich mal Testen, da ich auf diese möglichkeit schon sooooo lange warte...
    Ich melde mich wieder sobald ich es installiert und getestet haben.



    Gruß

  • Hallo Leute,


    ...bin begeistert, dass AirPlay endlich funzen soll.


    Was ich nicht gecheckt habe: funzt die Erweiterung mit einem TS209 II Pro? Es hat einen Marvell 5182 500MHz Prozessor.


    Danke für Info!


    Guitsch

  • hi guitsch


    leider nein

    Zitat

    There will not be a x09 [ARM] version because the kernel on that platform is to outdated.

  • Moin,


    So meine ersten Erfahrungen damit...


    hmm ich muss jetzt ehrlich sagen ich bin hier seit gut 1 1/2 Tagen am basteln aber zur Zeit geht einfach nichts...


    Remote App auf dem iPhone und iPad finden überhaupt keine Mediathek mehr, im iTunes wird zwar die AirPlay Freigabe vom NAS angezeigt und kann auf gerufen werden und auch Musik abgespielt werden. Das ist leider aber auch alles was geht.


    Naja werd mal weiter probieren!

  • n'abööönd


    hast du die posts genau durchgelesen? auch meine anleitung?

    Zitat

    Create a file with a random filename but with the extension .remote, on the first line enter the name of your device (for iphone you can find that out in iTunes) and on the second line enter the 4 digit code that you got from the app.

    verwende dazu einfach nen text editor. bei mir hat's unter windows mit dem editor (notepad) geklappt, jedoch nicht mit wordpad.

    Zitat

    First start the Remote app (by Apple), install from the App Store if you didn't do that yet, on your iOS device. Choose to add a library ["iTunes-Mediathek" in German] and then it gives you a randomly generated 4 digit code. This code you need to write in the second line of the whatever.remote file and then copy this file into the share on the NAS. Usually the Remote app should then immediately accept it, but if not just restart (disable/enable) the Airplay QPKG. After you did this pairing once (per iOS device), you don't need to do it again. It will automatically reconnect in future.


    You can use the Remote app to send your music (from the NAS / Airplay QPKG) to an AirPlay capable device like Apple TV or AirPort Express. It doesn't support local output.


    bin grad zu faul es nochmals auf deutsch zu schreiben :mrgreen: aber wenn was nicht klar ist, meld dich nochmal.


    im zweifelsfalle vielleicht den iphone namen mit itunes mal umbenennen in was einfaches - bei mir hat's mit apostroph zwar geklappt aber kann auch probleme machen. es muss der komplette name verwendet werden, standardmässig ist das sowas wie "Meinname's iPhone".

  • Moin


    Joa die Anleitung habe ich mittlerweile schon mehr fach gelesen...


    Das Problem ist ja auch das ich selbst mit meiner itunes Mediathek die ich auf meinem MAC habe keine Verbindung mehr zum Remote APP auf dem iPhone oder iPad bekommen.


    Ich habe jetzt gerade das NAS einfach mal ausgeschaltet... Siehe da jetzt funkt die Kommunikation zwischen MAC iTunes Mediathek und Remote APP + aTV2's wieder.
    Ich vermute das dass NAS bzw. die AirPlay Konfiguration auf dem NAS alles lahm legt, warum weiss ich noch nicht.


    Gruß

  • Hi,


    ich bin im englischen Forum nicht angemeldet.


    Gibt es auch eine Wiki in deutsch oder wird es solch eine geben?


    Danke

  • Chrissc1234 : keine ahnung woran das liegt, hatte das problem nicht. es wäre toll, wenn du das problem im englischen forum posten könntest, vielleicht kann internaut19 was rausfinden.


    @macQ: ich denke nicht. aber im englischen forum anmelden ist keine grosse sache und im zweifelsfall hilft google translate.

  • Hi,


    habe die beiden Programme installiert und eine Datei namens iPad.Remote in den Ordner Qmultimedia kopiert. In der Datei ist habe ich in der ersten Zeile den Namen. Jochen's iPad Geschrieben und in der zweiten Zeile den Code. Nach dem deaktivieren/aktivieren bekomme ich das iPad nicht angebunden.


    Ist das Verzeichnis korrekt?
    Kann es mit dem Namen des ipads Probleme geben?


    Da ich nur sehr mäßige Englisch Kenntnisse besitze wäre ich für jede Antwort dankbar!


    Gruß
    Jochen

  • ja das ist grundsätzlich richtig, irgendwas.remote. ich weiss nicht ob es ne rolle spielt ob man Remote oder remote schreibt, denke nicht. aber ich hab's immer klein geschrieben.


    mit welchem programm hast du die textdatei erstellt? unter windows hatte ich es zuerst mit wordpad gemacht, das ging nicht. danach hab ich es mit notepad (editor) versucht und damit ging es sofort. hat vielleicht was mit der zeichenkodierung zu tun.


    soweit ich weiss kann der apostroph n problem machen, der ist auch öfters mal "falsch" - es gibt diverse ähnliche zeichen die man teilweise nicht so einfach unterscheiden kann: http://de.wikipedia.org/wiki/A…ng_.C3.A4hnlicher_Zeichen. also im zweifelsfall ipad rasch verbinden und im itunes umbenennen (was einfaches ohne apostroph und ohne leerzeichen wählen)


    die datei am besten irgendwo anders erstellen (vollständig mit dem code, welcher die Remote app grade ausspuckt) und erst dann in die Qmultimedia/Multimedia freigabe kopieren. so klappt's bei mir in 90% der fälle sofort. nur selten musste ich dann noch das airplay qpkg beenden/starten. wichtig ist dass man dabei die Remote app offen lässt mit dem code auf dem display, sonst nix machen.

  • Danke für die Antwort. Habe das iPad umgenannt und alles so gemacht wie Du es beschrieben hast. Es funktioniert nicht..


    Ich habe mal im Log nachgesehen:


    Code
    1. [2011-09-12 18:56:49] raop: Couldn't make timing socket: Address family not supported by protocol
    2. [2011-09-12 18:56:49] raop: Couldn't make control socket: Address family not supported by protocol
    3. [2011-09-12 18:56:50] remote: Remote 'iPadJoK' not known from mDNS, ignoring
    4. [2011-09-12 18:56:50] remote: Remote 'iPadJoK' not known from mDNS, ignoring


    Also irgendetwas will da wohl nicht so....


    Hast Du noch eine Idee?


    Gruß
    Jochen

    Einmal editiert, zuletzt von Terz () aus folgendem Grund: CODE Blocks hinzugefügt

  • hast du das avahi qpkg vorher aktiviert? wird bei installation nicht automatisch gemacht.


    evtl. auch mal den nas rebooten.



    EDIT:

    Zitat

    ich bin im englischen Forum nicht angemeldet.


    qnap hat den bereich nun öffentlich geschaltet, so dass man die posts wenigstens ohne anmeldung lesen kann :) schreiben benötigt immer noch ein login.



    EDIT 2:
    eine kleine ergänzung hierzu

    Zitat

    Ersetzt den integrierten Bonjour Service (mDNSResponderPosix)

    Zitat

    Ersetzt den integrierten iTunes Server (mt-daapd)


    der integrierte bonjour service und itunes server werden NICHT gelöscht! die sind nach wie vor vorhanden und wenn man das avahi/airplay QPKG deaktiviert, werden automatisch die jeweils alten versionen wieder aktiviert! man kann das ganze also jederzeit rückgängig machen.

  • Ich bekomme leider auch weder iPad noch iPhone gepaart.
    iTunes findet den AirPlay Server ganz normal und kann auch davon abspielen.


    1. Avahi installiert und aktiviert
    2. iTunes Server aktiviert
    3. AirPlay installiert und aktiviert
    4. Mit Notepad (Win7) eine Datei mit 1. Zeile: iPad (Name in iTunes) 2. Zeile 0986 --> speichern "alle Dateien" iPad.remote
    5. Mit Filezilla in den QMultimedia geschoben


    --> Nichts passiert


    6. AirPlay Deaktiviert --> Aktiviert


    --> Nichts passiert


    7. QNap reboot


    --> Nichts passiert


    Den gleichen Vorgang mehrmals mit verschiedenen Codes probiert - nichts hat funktioniert :(

  • Kurzes Feedback: Auf QNAP TS-212 problemlos installiert. HD Remote hat sofort nach kopieren der .remote Datei das NAS erkannt. Abspielen funktionierte aber erst nach neustart des Airplays auf den QNAP.


    .remote Datei mit Notepad unter XP erstellt und mit dem Web-Dateimanager vom QNAP in den Multimedia-Ordner kopiert.

  • TheSoundAuthority : wenn du sehr viele songs hast, kann es eine weile dauern bis diese indexiert wurden (und soweit ich weiss wird das aktuell bei jedem start von forked-daapd gemacht, ist derzeit noch eine bekannte einschränkung). in englischen forum schrieb einer dass es erst danach ging mit dem paaren. warte mal etwas ab und versuch es nochmals.

  • Ok...das könnte das erklären. Was ich allerdings nervig finde ist, dass er auch alle .avis mit indexiert. Kann man das irgendwo ausschließen? Ansonsten habe ich bald noch den gesamten Familienurlaub in iTunes, die nicht abgespielt werden können.

  • Bei mir hat die Installation direkt funktioniert. *.remote mit Windows Editor erstellt und im Explorer in das Multimedia Verzeichniss gelegt. Server wird über die Remote App auf dem iPhone gefunden und zeigt auch die mp3´s an. Nur abspielen geht nicht. Wenn ich ein Lied auswähle springt das Bild für eine Sekunde zum Abspielbildschirm und dann direkt wieder zur Titelauswahl. QNAP und Airplay habe ich schon neugestartet.
    Irgendjemand eine Idee?


    Gruß
    Frank