Alternatives Betriebssystem - Windows Server (2019 Standard) auf einem QNAP NAS

[PROLOG]

Hier habe ich bereits beschrieben wie ich ein QNAP NAS mit dem alternativen Betriebssystem TrueNAS in Betrieb genommen habe und hier wurde die Frage gestellt, ob bereits jemand Windows Server auf einem QNAP NAS installiert hat. Eins und Eins macht ein neues Projekt, ist doch klar, also werde ich mich mal ranmachen und Windows Server 2019 auf einem QNAP NAS installieren.


Den Weg dahin und wie sich das verhält möchte ich hier kurz beschreiben.


[VORBEREITUNGEN]

Nach etwas „QuRoulette“ habe ich mich entschieden aus den zur Wahl stehenden NAS ein TS-453A mit 8GB RAM dafür zu verwenden, das Gerät erfüllt die Mindestanforderungen recht gut. Also ab damit in mein Testlab.

Für die Installation habe ich mir einen bootfähigen USB Stick mit Rufus erstellt, zuvor habe ich mir das gewünschte ISO Image heruntergeladen. In Rufus oben einfach den Stick wählen und rechts unter „Auswahl“ das Image, dann starten.

Anmerkung: "Testlab" klingt natürlich mega toll, in Wirklichkeit handelt es sich dabei aber um meinen nach Heizöl stinkenden Heizungsraum, in dem sich diverse Geräte stapeln sodass mir eine Firewall als Mauspad dienen muss... "Testlab" klingt aber geiler. :)


001_rufus.PNG

Bild 001 - Rufus


Für den produktiven Betrieb, sollte das Projekt erfolgreich sein, sollte der DOM des QNAP entfernt werden, denn zumindest nach meiner Erfahrung in dem o.g. Projekt mit TrueNAS hat sich herausgestellt, dass das NAS nachdem es von der Spannungsversorgung getrennt war, die Bootreihenfolge im BIOS so umstellt, dass als erstes vom DOM gebootet und somit QTS geladen wird. Bei Geräten mit festem DOM müsste man sich eventuell damit behelfen, dass der DOM gelöscht wird und nicht mehr davon gebootet werden kann. Alternativ muss man die Bootreihenfolge nach Spannungsausfall manuell umstellen, sofern dies überhaupt auf alle QNAP NAS zutrifft. In diesem Test lasse ich den DOM drin und kann anschließend einfach wieder davon booten, hoffe ich jedenfalls ;) .

Während der Installation eine neue Erkenntnis dazu:
Bei diesem Gerät wird die Bootreihenfolge sogar nach jedem Shutdown zurückgesetzt!


Jetzt noch Tastatur und Monitor und für einen „Mausschubser“ wie mich natürlich noch eine Maus an das NAS gesteckt, den Installationsstick rein und schon geht die Reise los.


Übrigens: Manche QNAP NAS haben keinen Monitoranschluss, sind deshalb aber nicht für solche Projekte unbrauchbar. Diese verfügen i.d.R. über eine 3,5mm Buchse als Console-Port. So ein Kabel gibt es sicherlich käuflich zu erwerben, ich habe mir aber auch schon selbst eins gebaut. Damit sollte man theoretisch mittels Putty ins BIOS kommen und die Installation vornehmen können. Später muss man halt alles per RDP o.ä. machen. Getestet habe ich das allerdings nicht.


[INSTALLATION]

Nachdem das NAS eingeschaltet wurde müssen wir mit der Taste „ENTF“ ins BIOS gehen und die Bootreihenfolge umstellen, zunächst auf den Installationsstick. Alternativ könnte man auch das Bootmenü aufrufen, was mir bei QNAP NAS bislang aber nicht geglückt ist, deswegen gehe ich den Weg über das BIOS, was später ohnehin erforderlich ist, wenn trotz installiertem DOM von dem Datenträger auf dem Windows Server installiert ist gebootet werden soll.

Hinweis: Das BIOS erreicht man bei manchen QNAP NAS erst relativ spät nach dem Einschalten, sobald der Monitor kurz nach dem ersten Beep ein erstes Bild zeigt.


002_BIOS_1.jpg

Bild 002 - BIOS Bootmenu - Installations-Stick


Ist die Bootreihenfolge angepasst und die Einstellungen gespeichert, startet das NAS neu und es erscheint erwartungsgemäß der Installationsassistent von Windows Server, den man entsprechend seinen Vorlieben durchläuft und die Einstellungen vornimmt. Ich habe mich für Windows 2019 Standard mit grafischer Oberfläche entschieden. Anschließend kommt der erste kritische Punkt, zumindest wenn man den DOM nicht entfernt hat, denn bei der Auswahl auf welchem Datenträger Windows Server installiert werden soll, tauchen auch Partitionen des DOM auf, die nicht angetastet werden sollten, sofern man das NAS später nochmal ohne weitere Maßnahmen mit QTS verwenden möchte.


003_Datenträgerauswahl.jpg

Bild 003 – Datenträgerauswahl für Windows Server Installation


Einzige Auffälligkeit bislang: Beim Installationsprozess wurde mir zunächst kein Fortschritt (Prozentangabe) angezeigt, es stand stets bei 0%, aber ich konnte an der Datenträger-LED am NAS erkennen, dass hier gearbeitet wird. Später gab es dann doch eine Fortschrittanzeige.


Nach der Installation wird der Installationsstick entnommen und die Reise geht zurück ins BIOS wo die Bootreihenfolge auf den Windows-Datenträger als #1 umgestellt wird. Dies ist nach der Installation auch direkt der Fall.


004_BIOS_2.jpg

Bild 004 - BIOS Bootmenu - Windows Boot Manager


Nach einem erneuten Reboot lädt dann auch schon Windows Server 2019 und kann verwendet werden. Das Ganze ist dabei auch alles andere als langsam… das Starten hat -nach der obligatorischen Wartezeit bis zum ersten Beep- gerademal 30 Sekunden gedauert…


[VERHALTEN VON WIN SERVER AUF EINEM QNAP NAS]

… und auch die Bedienung war anschließend sehr flüssig mit kurzen Ladezeiten.


005_Win_Info.PNG

Bild 005 - Windows Systeminfo


Die spannendste Frage wird wohl sein, ob Windows Server mit der Hardware des QNAP klarkommt. Ich habe da wenig Zweifel, da ich Windows seit einigen Jahren als sehr hardwarefreundliches OS betrachte.

Ganz so dolle scheint das aber dann doch nicht der Fall zu sein, denn im Gerätemanager tauchen einige unbekannte/ nicht verwendbare Geräte auf, darunter u.a. der Infrarotcontroller und ein Serial-IO Controller sowie ein SD-Controller. Naja wenn es weiter nichts ist… ansonsten sieht das gut aus!


006_Gerätemanager.PNG

Bild 006 - Windows Gerätemanager


Das Display am NAS kann man allerdings abschreiben, bzw. sollte man abklemmen, denn dies zeigt erwartungsgemäß stets „System booting“ und erlischt nicht, auch die beiden Tasten zur Bedienung sind ohne Funktion.
In meinem Fall mit installiertem DOM sehe ich dessen Partitionen natürlich auch unter Windows... das ist etwas nervig und man muss wieder aufpassen, dass man hier nichts kaputt macht, sofern man später halt nochmal QTS in Betrieb nehmen möchte... ansonsten sollte der DOM raus oder seine Partitionen gelöscht werden... macht sich sicherlich nicht schlecht für die Auslagerungsdatei wenn er schnell genug angebunden ist... naja jedenfalls wenn man ein Gerät mit einem 4GB statt 512MB DOM hat :S

Ein Blick in den Taskmanager auf die Systemressourcen verrät, dass die CPU recht gut ausgelastet ist, obwohl noch nichts eingerichtet wurde, allerdings weiß ich auch nicht, welche Dienste hier nach der Installation bereits laufen. Aber… wie konnte ich es vergessen?! Im Hintergrund werden bereits Updates installiert, die fast die gesamte CPU Last verursachen, also alles gut.


007_Ressourcen.PNG

Bild 007 - Taskmanager Ressourcen


Das System rennt einfach, bis hierhin absolut problemlos, flüssig und stabil, weiß adhoc aber auch nicht, was ich noch weiter testen kann. Für heute reicht es auch erstmal.



So wirklich aufregend war das Projekt nicht, umso mehr freue ich mich aber darüber, dass es so reibungslos lief. Etwas flau ist mir nun aber doch... ich habe ein QNAP Betriebssystem durch eins von Microsoft ersetzt… ob das der große Sprung ist? Egal, ich weiß wie man mit solchen Zweifeln umgeht… cheers! :beer:

Kommentare 20

  • Ich hab seit 2-3 Jahren bereits unRAID via USB-Stick an meiner alten TS-453mini im Einsatz, läuft einwandfrei.

    Netterweise hab ich mal versucht, das QNAP-eigene OS als VM darauf laufen zu lassen, was ironischerweise zunächst an der HW-Prüfung scheiterte - aber irgendwann lief es, und zwar genau so schnell/langsam wie das Original.


    Da mir aber die QNAP-eigenen User-"Experimente" in Form von OS-Updates schon des Öfteren zuvor die Haare zu Berge stehen lies, hab ich die VM gelöscht und lasse seitdem unRAID weiterhin darauf laufen - so wie hier das gesamte restliche x86 "Keller"-Equipment - und es läuft und läuft und läuft und läuft ...

    • unRAID habe ich wegen der Kosten noch nie für meine Spielereien berücksichtigt (30 Tage zum Testen wäre mir zu doof), kann mir aber vorstellen, dass das eine wirklich gute Lösung ist. Die Preise sind ja auch echt überschaubar. Wenn das Thema bei mir mal ernst wird und nicht nur Spielerei ist, würde ich das auf jeden Fall auch in Betracht ziehen.

    • Ich kann es nur jedem empfehlen, der über eine Fix&Fertig-Kauflösung beim NAS hinaus will, vor allem dann, wenn es um virtuelle Maschinen geht.

      Mein Setup im Wohnzimmer ist ein lautloser Thin-Client mit 10GB-Fiber-Anbindung, der Host ist das unRAID-Setup im Keller.

      Wenn ich dann auf 4k bspw. das Zocken anfange und dann via Tastenkombination auf eine andere VM umschalte, auf der gerade ein Video-Renderer unter Volllast läuft, sind die Gesichter derjenigen, die das das erste Mal sehen, genial (riesengroßes Fragezeichen, wo ist der Lärm, wo der PC?).

      Sobald ich das auflöse und die Kosten dafür erkläre, kann man bei etlichen erkennen, dass sie sich in den Hintern beißen für Ihr Setup....

    • Aber das wuppt dann doch nicht die 453mini, oder?

    • Nein, das ist ein Ryzen-Setup - mit insgesamt 3 Grafikkarten (2xNVIDIA 2080Ti + 1x AMD) - aber die 453 wurde mit 2x5GB-USB3-Adaptern ans LAN angebunden, und mit 4x8GB-WD-RED + 16 GB RAM sind dann 500-600MB/s Storage-Anbindung drin ...

  • Also ich kann ohne riesen Aufwand ein anderes Betriebssystem verwenden? Klappt das wohl auch mit einer TS-251D ?

    Ich habe das zwar jetzt nicht vor aber in ein paar Jahren vielleicht.


    Ich hab mich auch noch nicht getraut meine Zyxel NSA325v2 mit einem anderen OS zu Betreiben. Da ist allerdings auch kein Bootmenü oder Monitor dran nutzbar.

    • Sollte auch mit dem 251D kein Problem sein, je nach OS ist natürlich die Hardware/ Leistung entscheidend. Ich wollte demnächst auch mal FreeNAS testen, das könnte auch auf schwächeren Systemen gut laufen.


      Ein anderes OS ohne Monitor zu installieren habe ich noch nie versucht, keine Ahnung wie das gehen mag wenn es auch keinen Konsolenanschluss gibt über den das ggf realisierbar sein könnte.

  • Ein kleines Manko hat das Projekt allerdings: NAS kostet 700.- Euro, die Windows Server 2019 so um die 1‘000.-. Mir ist klar, dass Du hier die Trial verwendet hast, aber die läuft ab.

    • Darüber habe ich mir ehrlich gesagt gar keine Gedanken gemacht... Die Frage ob es geht kam halt auf und ich hab probiert, betreiben will ich das gar nicht :)

      Wäre also wohl nur etwas wenn man noch eine solche Lizenz "rumliegen" hat ;)

    • Die Windows Server Testversion kann bis zu fünf mal um jeweils 180 Tage verlängert werden. Damit kann man Win Server fast drei Jahre kostenlos nutzen, bis eine Neuinstallation fällig wird. Für ein kostenloses Windows ist das eine gute Zeit. (Hinweis: Ich meine gelesen zu haben, dass die Verlängerung nur geht, bevor der Zeitraum abläuft. Man sollte sich die Zeitpunkte daher gut im Kalender markieren.)


      Bei mir läuft Windows Server 2019 auf dem Qnap in einer virtuellen Maschine. Ein Kunde möchte mein Programm unbedingt auf Win Server nutzen. Mit der VM kann ich bei Bedarf jederzeit einen schnellen Test machen.

  • Toller Test, mit DOM wäre mir ganz schön mulmig gewesen ob das NAS danach noch läuft


    das Bootmenü beim 253a kommt wenn du F7 beim booten befeuerst :)


    mit dem Driverpack offline full solltest du den fehlenden Treibern bei kommen normalerweise ist da immer einer dabei

    Gefällt mir 1
    • Werde das mit den Treibern mal testen... Haste ne Quelle für mich?

      Dann sammeln wir hier mal was noch geprüft werden kann und dann gehe ich die Tage noch mal bei :)

    • driverpack.io 28GB Link nur über torrent aber direkt von denen

    • Frage: Wenn ich das WTS im DOM lösche, kann ich das dann danach jederzeit wieder problemlos wie bei einem Firmware-Update einspielen?

    • Frage 2: Hast du vor der Installation Secure Boot im sog. BIOS deaktiviert?

    • Wenn QTS auf dem DOM gelöscht wird, muss vor der Wiederinbetriebnahme ein Firmware Recovery erfolgen, damit wird der DOM wieder mit QTS beschrieben. Ganz so einfach wie ein FW Update ist das also nicht. Etwaige HDD mit dem eigentlichen QTS und den Einstellungen bleibenden unberührt und können direkt wieder verwendet werden.


      Am BIOS habe ich gar nichts außer die Bootreihenfolge angefasst .