QTS 4.3 - Let's Encrypt SSL Zertifikat mit wenigen Klicks erstellen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • In der neuen QTS 4.3 Version wurde Let's Encrypt direkt in das Betriebssystem implementiert.
    In meinem Fall habe ich schon ein bestehendes SSL Zertifikat, daher gibt es minimalste Abweichungen, aber die Schritte sind identisch.

    Mit wenigen Klicks, kann man sich ein SSL Zertifikat für die NAS erstellen:



    Wenn man noch kein Zertifikat hat, dann heißt der Button nicht "Zertifikat ersetzen", sondern "Zertifikat erstellen".












































    im Feld mit der Nummer 3, kann ein zusätzlicher DNS-Name angegeben werden, ist aber optional.



















    Mit diesen wenigen Schritten hast du dir nun ein Let's Encrypt SSL Zertifikat erstellt :)


    Hinweise:
    Vor Ablauf der Gültigkeit soll man eine Nachricht an die Email-Adresse bekommen, die man bei der Zertifikateinrichtung hinterlegt hat. Das Zertifikat kann aber auch vor der Email-Nachricht erneuert werden. So die Aussagen auf der QTS 4.3 World Tour.

    Jede Zertifikateinrichtung bedarf einer Authentifizierungsprüfung. Das heißt, dass der Zertifikatsaussteller überprüfen muss, ob derjenige der das Zertifikat beantragt auch dazu berechtigt ist. Lets Encrypt überprüft dazu bei der Einrichtung und bei jeder Erneuerung, ob das Nas mit der Domäne-Adresse über Port 80 erreichbar ist. Es muss im Router eine Weiterleitung von Port 80 auf die interne IP-Adresse der Nas eingerichtet sein. Wenn UPnP in Router und Nas aktivert ist, erstellt sich die Nas die Freigabe automatisch selber. Es ist aber empfehlenswert als Admin die Übersicht über die Freigaben zu halten und diese Aufgabe der Nas nicht zu überlassen. UPnP im Router also nicht zu aktivieren. Grundsätzlich gilt aus Sicherheitsgründen auch weiterhin, dass nur die Ports am Router geöffnet sein sollen, die unbedingt benötigt werden. Sofern man keine anderen Webdienste nutzt, über die die Nas über Port 80 im Internet erreichbar sein muss, empfiehlt es sich, den Port 80 nur kurzfristig für die Zertifikatserstellung bzw. -erneuerung zu öffnen und dnanach wieder zu schließen.

    Danke an @phoneo für die Bereitstellung der Hinweise-Texte!

    3.405 mal gelesen

Antworten 78

  • hanswalter88 -

    @Hubert00: Welchen DDNS verwendest du? Falls nicht ohnehin versucht, schalte den myqnapcloud.com ddns ein und versuche, falls vorhanden, deinen eigentlichen DDNS als Alternativen Namen zu registrieren. Folgerichtiger Weise vorher kurz checken ob der…

  • Hubert00 -

    Zitat von libertyx82: „Von intern und extern? “ Ja, Zugriff auf den Webserver ist problemlos möglich (beiderseits). Zitat von hanswalter88: „Habe also die SSL Zertifizierung nur über IPv4 durchführen können, danach im dyndns wieder die IPv6…

  • hanswalter88 -

    Hallo zusammen, ich hatte das gleiche Problem: Fehlermeldung: "Authentifizierung fehlgeschlagen. Bitte prüfen Sie den DNS Server oder schauen Sie nach, ob Port 80 funktioniert." Konnte es mithilfe eines netten Kundensupports von Qnap per Teamviewer…

  • libertyx82 -

    Von intern und extern? Damit ist auch nicht die WebGUI (QTS) gemeint.

  • Hubert00 -

    Ja, Webserver läuft und ist erreichbar.

  • libertyx82 -

    Ist denn der Webserver der QNAP aktiv und erreichbar?

  • Hubert00 -

    Es funktioniert noch immer nicht ?( (Port 80 ist definitiv zu erreichen) forum.qnapclub.de/attachment/1…99d1a73150133958498652276

  • iMactouch -

    Zitat von Doc HT: „Damit fällt diese Lösung für mich aus - zu gefährlich. “ Es geht nur um das Einschalten, während das Update von Letsencrypt läuft (ca. 1min). Danach wird das natürlich wieder abgeschaltet.

  • Doc HT -

    Danke für die Info. Damit fällt diese Lösung für mich aus - zu gefährlich. Also muss wohl mindestens der Webserver auf dem NAS laufen und Port 80 offen sein. Kann das jeman bestätigen? Welche Ports braucht Let's encrypt noch, und welche…

  • iMactouch -

    Das schrieb ich doch schon, ich habe kurzzeitig den "exposed Host" für den QNAP in der Fritzbox eingeschaltet. Damit ging es auf Anhieb.