Probleme WebDAV, Webserver und Port-Weiterleitung

Webserver + Apache + PHP + MySQL/SQLite

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon Käpsele » Do 8. Jul 2010, 09:20

Danke fĂĽr die Antwort,

nur werde ich daraus nicht schlau. Wenn es am Port oder an der SSL Aktivierung liegen wĂĽrde, dann wĂĽrde ich ja gar nicht erst bis zur Passwort-Anmeldung kommen- oder?
Und was mir der Link zeigen soll, verstehe ich leider auch nicht?
Käpsele
 
Beiträge: 7
Registriert: So 4. Jul 2010, 19:32

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon anton001 » So 29. Aug 2010, 20:15

Hallo zusammen,

ich habe leider das gleiche problem und leider auch noch keine lösung gefunden. Hat mittlerweile vielleicht etwas gefunden?
Vielen Dank schon mal!

Anton
anton001
 
Beiträge: 111
Registriert: Fr 14. Aug 2009, 12:12
Skype: lebedev.anton

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon Käpsele » So 29. Aug 2010, 22:34

Ja, es gibt in der Zwischenzeit eine Antwort vom QNAP-Support.

Leider unterstĂĽtzt Windows 7 (noch) kein WebDAV. :(

Wer also Windows 7 hat, darf sich zumindest vorläufig eine andere Lösung überlegen.
Käpsele
 
Beiträge: 7
Registriert: So 4. Jul 2010, 19:32

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon anton001 » Mo 30. Aug 2010, 12:24

Hi Käpsele,

also diese Aussage kann man ja so nicht stehen lassen :-/ , denn bei mir funzt ja Webdav ĂĽber Port 80 also ungesichert.
Was bei mir nicht funktioniert ist der gesicherte Zugang mit Webdav. Nach meinem Verständnis bis jetzt hat das was mit dem Zertifikat zu tun.
Bei mir verwende ich ja noch immer den mitgelieferten Zertifikat von TS NAS Series, den habe ich mittlerweile mit Snap-In nach Win7 importiert aber leider mag Win7 den in Verbindung mit meiner DynDNS nicht, anscheinend muss der CN (common name) mit der Dyndns der NAS übereinstimmen. Ich bin da noch nicht weitergekommen (Arbeit, Frau blabla) aber es scheint ein vielversprechender Ansatz zu sein. Man müsste sich wohl ein Zertifikat erstellen (ich weiß nicht ob man den von QNAP so bearbeiten kann, dass dort der CN geändert wird, aber ich vermute nicht) der als CN die DynDNS der NAS enthält und danach müsste es klappen. Wenn jemand die folgende Anleitung schon mal ausprobieren will wäre das ganz toll!
http://www.computerbase.de/forum/showthread.php?t=707192
Ich bin leider nicht so vertraut mit apache, linux, openssl usw. d.h. es wird bei mir dauern bis ich da selbst durchsteige ;)

Anton
anton001
 
Beiträge: 111
Registriert: Fr 14. Aug 2009, 12:12
Skype: lebedev.anton

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon Käpsele » Mo 30. Aug 2010, 13:09

Na-ja,

vielleicht reichen auch meine Englisch-Kenntnisse nicht aus und ich habe die Antwort falsch interpretiert.

Hier die original Antwort vom Support:

"Sorry that currently WebDAV function on our NAS doesn’t support Windows 7. It only support Windows XP/Vista."

und auf meine Nachfrage, ob eine Lösung absehbar ist:

"This is valid for all series of NAS.
Currently we have no schedule for the solution of this problem since this problem looks like Windows 7’s poor support of webdav. "


Aber wenn es bei dir ohne SSL funktioniert, dann gratuliere ich schon mal und wĂĽrde mich ĂĽber eine Anleitung freuen, wie ich es auch einrchten kann.

schöne Grüße

Käpsele
Käpsele
 
Beiträge: 7
Registriert: So 4. Jul 2010, 19:32

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon pointde » Mo 30. Aug 2010, 13:23

Funktioniert bei mir auch mit Windows 7!!!
pointde
 
Beiträge: 132
Registriert: Di 21. Apr 2009, 10:20
Plz/Ort: tiefer, böser Bayerischer Wald

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon Käpsele » Mo 30. Aug 2010, 14:21

Danke für den Tipp, wenn ich jetzt noch gesagt bekomme, was ich tun muss, damit es auch bei meinem Windows 7 funktioniert, dann wäre ich glücklich.
Käpsele
 
Beiträge: 7
Registriert: So 4. Jul 2010, 19:32

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon vanhaakonnen » Mo 30. Aug 2010, 18:20

Also bei mir klappt es jetzt auch unter Windows 7 sowohl via http alsauch via https. Unter Ubuntu ging es von Anfang an.

Das Problem scheint bei Windows 7 zu sein, dass er keine selbstsignierten Zertifiakte akzeptiert. Bei StartSSL kann man sich jedoch ein offizielles und fĂĽr ein Jahr gĂĽltiges Zertifikat holen.

Dazu wie folgt vorgehen:
Auf einer Linux-BĂĽchse muss der Private-Key und der Zertifikatsantrag erstellt werden:
openssl genrsa -out example.com.key 2048
openssl req -new -key example.com.key -out example.com.csr

Bei StartSSL unter http://www.startssl.com/?app=12 der Express Lane folgen, Bestätigungscodes alle brav eintippen und abwarten. Per copy & paste irgendwann die csr - Datei einfügen. Das signierte Zertifikat kann man sich dann herunterladen.

In der QNAP-Oberfläche gibt man nun Sicherherit, Wichtiges SSL-Zertifiat im oberen Feld den Inhalt des signierten Zertifates ein und im unteren den Private-Key (example.com.key).

Jetzt hat der QNAP schonmal an sich das offizielle Zertifkat. Leider fehlt dem Ganzen aber noch die Chain - sprich der Zertifikatsbaum der CA. Diesen muss man per Hand einfĂĽgen:
In folgenden Ordner wechseln: /etc/stunnel/
wget http://www.startssl.com/certs/sub.class1.server.ca.pem
vi /etc/config/apache/extra/apache-ssl.conf
folgende untere, eine Zeile aufnehmen unter der "SSLCertificateFile" Zeile:
SSLCertificateChainFile "/etc/stunnel/sub.class1.server.ca.pem"
/etc/init.d/Qthttpd.sh restart

Dann ggf. im Browser nochmals mit F5 aktualisieren und iht habt ein offzilles, signiertes Zertifikat am Start. Danach ging bei mir auch unter Windows 7 alles via Webdav.

VanHaakonnen
vanhaakonnen
 
Beiträge: 17
Registriert: So 19. Jul 2009, 21:37

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon anton001 » Mo 30. Aug 2010, 18:34

oh wow

könntest Du das nochmal für dummies beschreiben, also für so richtige dummies :)
welche Linux-BĂĽchse zum Beispiel?

Danke schon mal

Anton
anton001
 
Beiträge: 111
Registriert: Fr 14. Aug 2009, 12:12
Skype: lebedev.anton

Re: Probleme WebDAV, Webserver und Port-Weiterleitung

Beitragvon anton001 » Mi 1. Sep 2010, 10:11

Hi Käpsele

Käpsele hat geschrieben:"Sorry that currently WebDAV function on our NAS doesn’t support Windows 7. It only support Windows XP/Vista."


naja das heisst ja genau genommen, dass das NAS den Win7-WebDav nicht unterstĂĽtzt

Käpsele hat geschrieben:und auf meine Nachfrage, ob eine Lösung absehbar ist:
"This is valid for all series of NAS.
Currently we have no schedule for the solution of this problem since this problem looks like Windows 7’s poor support of webdav. "


Und das ist wohl wahr. Nach allem was ich bis heute weiss, ist WebDav bei Win7 ziemlich verrunzt. Aber wie gesagt ohne SSL funzt es ja und mit SSL anscheinend auch nur ist es eben wegen der strikten Auffassung von Sicherheit seitens Win7 etwas tricky. Ich bin noch nicht soweit, dass ich es selbst lösen kann :(

Käpsele hat geschrieben:"Aber wenn es bei dir ohne SSL funktioniert, dann gratuliere ich schon mal und würde mich über eine Anleitung freuen, wie ich es auch einrchten kann."


na dann ich versuchs mal:

eigentlich läuft es ziemlich so ab wie im handbuch beschrieben:

Router:
1. Port 80 auf NAS weiterleiten (siehe hierzu das manual deines routers!) Bei meinem ist es ziemlich einfach ich wähle die LAN IP meiner NAS und gebe bei "Portweiterleitung TCP" 80 ein, bestätigen. Fertig!

NAS: (Reihenfolge der Schritte beachten. Falls bei dir jetzt die Freigabe schon irgendwo drin ist aber der Webserver/Webdav inaktiv musst du die Freigaben ersteinaml rausnehmen und dann wieder die Schritte nacheinander befolgen)
2. Webserver aktivieren
3. WebDav aktivieren (Sichere Verbindung nicht aktivieren!)
4. Den gewünschten Ordner bei "Zugriffskontrolle">>"Freigabeordner">>"WebDav-Zugangskontrolle"(blauer-Kreis-Icon)>>"Zugriffsrecht" für den/die gewünschten User auswählen (also Schreibgeschützt oder Vollzugriff)
Achtung! die gleichen Rechte gelten für alle ausgewählten User und die entsprechenden User müssen auch schon unter "Zugriffskontrolle" (Ordner-in-derHand-Icon) dieselben Rechte haben.
5. Kontrolle der Portweiterleitung - Nach Schritt 4 solltest du mit deinem Browser ĂĽber das Internet zu deiner NAS navigieren also von auĂźen nicht aus dem LAN (Internetadresse in der Adressleiste nicht LAN-IP)! Auf der Anmeldeseite solltest du nun auf Webserver klicken wenn du auf die Seite kommst wo die Anbindung mit WebDav beschrieben wird kommst dann funktioniert die Portweiterleitung, ansonsten (also wenn du "Seite kann nicht erreicht werden"-Meldung bekommst dann zurĂĽck auf Anfang.

Win7:
6. Folgende Anleitung befolgen http://support.microsoft.com/kb/928692/de
Achtung! Neustart nicht vergessen.
Anbinden der Webdav-Freigabe (geht eigentlich genauso wie im QNAP Manual beschrieben, du brauchst fĂĽr Win7 den dort angesprochenen Update nicht, bei 64-Bit System sowieso nicht)
8. Computer>>Netzlaufwerk verbinden>>Verbindung mit einer Website herstellen...>>Weiter>>Eine benutzerdefinierte Netzwerkadresse...>>Weiter>>im Feld fĂĽr die Adresse, deine NAS-Adresse eingeben:
http://deinenasdyndns oder deinenasip/freigabeordner>>Weiter>>Username und Passwort des Users für den die Freigabe mit Zugriffsrecht erteilt wurde eingeben>>Bestätigen
9. Fertig!!!

So hat es bei mir funktioniert. Leider kann ich es ohne sicheren Zugriff also SSL nicht gebrauchen :(
Ich hoffe es klappt so bei dir auch, viele GrĂĽĂźe

Anton
anton001
 
Beiträge: 111
Registriert: Fr 14. Aug 2009, 12:12
Skype: lebedev.anton

VorherigeNächste

ZurĂĽck zu Web Applikationen

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast